Lets encrypt for emails, ftp etc... like plesk and cpanel

Discussion in 'Installation/Configuration' started by ariban99, Jun 25, 2020.

  1. ariban99

    ariban99 Member

    Hi
    In Cpanel and Plesk when you create letsencrypt SSL it asked you do you want to use this for all services including email, ftp, ssh etc...
    then we can encrypt our emails.
    is there a way to do this in ispconfig?
     
  2. Th0m

    Th0m Active Member HowtoForge Supporter

  3. ariban99

    ariban99 Member

    thank you for your reply, i dont know what i am doing wrong i get this error from the github
    ./le4ispc.sh: line 28: certbot: command not found

    as for the second howtoforge page, i must not be doing it right either as its also not working for me
    any ideas?
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you tried the instructions again, following them very carefully?
    Perhaps you have not installed certbot, but instead certbot-auto, in which case the command is
    Code:
    /opt/eff.org/certbot/venv/bin/certbot
    at least on my host. May differ on your host, depending on where you installed it.
     
  5. Th0m

    Th0m Active Member HowtoForge Supporter

    Did you install your server following the Perfect Server tutorial?
     
  6. ariban99

    ariban99 Member

    i followed this tutorial
    https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/
    i see the part that i did
    cd /usr/local/bin
    wget https://dl.eff.org/certbot-auto
    chmod a+x certbot-auto
    ./certbot-auto --install-only
    yes you are right its certbot auto, i will try what you said and see if that works
     
  7. ariban99

    ariban99 Member

    so i did this
    /opt/eff.org/certbot/venv/bin/certbot
    and it seems to have created an SSL, but how do i make it for emails, ftp etc...
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Do you not read the answers you get? @Th0m told you that in #2.
     
    Th0m likes this.
  9. ariban99

    ariban99 Member

    no i read the answers, but
    Take a look at this: https://github.com/ahrasis/LE4ISPC by @ahrasis this gives me the same error still
    ./le4ispc.sh: line 28: certbot: command not found
    i ran your command /opt/eff.org/certbot/venv/bin/certbot and it asked me which domain i want the SSL, i selected the domain but it didnt do anything else and that domain still doesnt have an SSL even after running the command posted
    as for https://www.howtoforge.com/tutorial/securing-ispconfig-3-with-a-free-lets-encrypt-ssl-certificate/ i tried this but for some reason its not working either.

    i guess i will wait till an update comes to do this automatically, as he wrote on his last line
    There is a feature request to do this automatically: https://git.ispconfig.org/ispconfig/ispconfig3/-/issues/3987
     
  10. Th0m

    Th0m Active Member HowtoForge Supporter

    My guess is that you didn't install certbot as explained in the Perfect Server tutorial, or maybe your path is wrong, did you use su or su -?
     
  11. Th0m

    Th0m Active Member HowtoForge Supporter

  12. ariban99

    ariban99 Member

  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorial states that you must create a website for the server name in ispconfig and activate SSL and Let's encrypt for it in ISPConfig, and Th0m asked you if you really did that. Btw. I used that tutorial recently and it worked fine on my server.
     
  14. ariban99

    ariban99 Member

    yes i did
    but for some reason a website for the server name (webserver.bhsolutions.com) when i click SSL and letsencrypt it doesnt work for some reason
     
  15. ariban99

    ariban99 Member

    i think im not good enough for this, i need more learning and i might need to pay for plesk or cpanel for now to dumb things down for my level
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    When Let#s encrypt refuses to issue an SSL cert for your ISPConfig installation, then it won't issue one for your Plesk installation, so buying a Plesk license will just cost you money but this will not make LE to issue a cert for you, they simply don't care if you use Plesk or ISPConfig. If you want to know why LE refused to issue you an SSL cert, take a look at the FAQ that I posted above.
     
  18. ariban99

    ariban99 Member

    thank you i will do that.
    can it be that my name domain (my server is the subdomain.mymaindomain) has a regular SSL and not letscrypt, so if i create a new website called subdomain.maindomain, can that be why its not creating a letsencrypt ssl?
     
  19. ariban99

    ariban99 Member

    im going to go through the steps in the website you gave me to try to find out why its not working
     
  20. Th0m

    Th0m Active Member HowtoForge Supporter

Share This Page