Let's Encrypt creates a certificate for www. but not for .

Discussion in 'Server Operation' started by ircf, Apr 9, 2018.

  1. ircf

    ircf Member

    First thank you for ISP Config 3, it really is an awesome tool, we use it every day !

    I have a little problem when I create a website on ISPConfig 3.1.6 :
    - On Domain Tab : I create a website say example.com, select auto subdomain "www", check SSL and Let's Encrypt, then Save
    - On Redirect Tab : I check rewrite HTTP to HTTPS and Save
    Let's encrypt creates a SSL certificate for www.example.com but not for example.com (I expected to have both in a single SSL cert).

    For now the solution I have found is to create the website without the "www" auto subdomain, then create manually an alias with www (I haven't tested with a subdomain), then LE creates a SSL certificated with both . and www.

    Is it an expected behaviour or is there a fix for that ?

    Thank you :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try this instead:

    Create we website with auto alias www but do not enable the LE checkbox. Press save. Open the site settings again and enable the LE checkbox and press save.
  3. ircf

    ircf Member

    Thank you for your fast answer :)
    I'll try this next week and I'll tell you. (I prefer not to generate LE too often to avoid reaching my quota).

Share This Page