Let's Encrypt and changed PHP.ini options destroys encryption

Discussion in 'Installation/Configuration' started by Pay87, Jan 27, 2017.

  1. Pay87

    Pay87 New Member

    first of all the default setup of a perfect Ubuntu Server with Apache and ISPConfig 3 works very vell with Lets Encrypt.

    But as soon as I add some directives to a vhost php.ini option in ISPConfig3 and save it (like changing max upload size). Then it seems like the vhost is not using the Let's Encrypt certificate anymore with the result, that the browser claims that the connection is not secure anymore.

    Is there anything I can do against it? As soon as I remove the custom options inside the php.ini field and toggle the Let's Encrypt option, then everything is working fine again.
    Thank you
  2. sjau

    sjau Local Meanie Moderator

    what did you add exactely? And please provide URL to where cert isn't ok.
  3. MarsWarrior

    MarsWarrior New Member

    If it is the same problem as I encounter a lot: ISPConfig doesn't generate the *:443 part of the vhost file.

    You can check the vhost file if the https part is missing. If so, change something in that website's config in ISPConfig and save again...
  4. Pay87

    Pay87 New Member

    I cannot provide a link, because its a live site and now it is fine again, after I removed the custom php.ini from the vhost config options. I just added "upload_max_filesize = 10M". After saving the options inside ICPConfig, the ssl is not working anymore over Lets Encrypt. I have both enabled for the VHost. LetsEncrypt and SSL checkbox, could this be the problem? Thank you

Share This Page