Let's doesn't work with php70 (without php70 works)

Discussion in 'Installation/Configuration' started by Daniel Resler, Nov 10, 2019.

  1. Daniel Resler

    Daniel Resler New Member HowtoForge Supporter

    Good day,
    CENTOS 7 + ISPCONFIG 3.1.15p2 + PHP7 + LET'S.
    If I set SSL Let's Encrypt SSL, the certificate is generated. Website shows certificate OK. However, if you set up PHP: PHP-FPM and PHP Version: PHP70, the certificate will not be displayed for the HTTPS: page. If I disable PHP, the certificate is OK.
    Any advice, please?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Daniel Resler likes this.
  3. Daniel Resler

    Daniel Resler New Member HowtoForge Supporter

    The behavior is the same on other PCs (MAC, WIN, MOBIL, etc.). If PHP is disabled, LETS CERT will load correctly, if it is active it will report an unsecured connection.
    I appreciate your help!
    d.r.
     
  4. ahrasis

    ahrasis Well-Known Member

    Personally, I do not know centos that well but do check your php installation.
     
  5. Jesse Norell

    Jesse Norell Well-Known Member

    PHP happens in the web server backend, and is independent of whether the web client<->server connection is encrypted or not. Perhaps when you turn on PHP, your php website is redirecting you from your https site to a http location? You might try creating a .html file and load that directly, with no php processing, and ensure that https works with or without php enabled; if it doesn't, something else changed, eg. the site ip address.
     

Share This Page