Letencrypt new installation error

Discussion in 'Installation/Configuration' started by Stelios, Nov 21, 2020.

  1. Stelios

    Stelios Member HowtoForge Supporter

    Hi,

    I've tried to add a new email server to my multi-server setup and during the installation, I got the following error:
    Code:
    Do you want to create SSL certs for your server? (y,n) [y]: y
    
    Checking / creating certificate for email3.mydomain.com
    Using certificate path /etc/letsencrypt/live/email3.mydomain.com
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Plugins selected: Authenticator standalone, Installer None
    Running pre-hook command: letsencrypt_pre_hook.sh
    Output from letsencrypt_pre_hook.sh:
    Firewall is active and enabled on system startup
    Rule added
    Rule added (v6)
    
    Obtaining a new certificate
    Performing the following challenges:
    http-01 challenge for email3.mydomain.com
    Waiting for verification...
    Cleaning up challenges
    Running post-hook command: letsencrypt_post_hook.sh
    Hook command "letsencrypt_post_hook.sh" returned error code 2
    Error output from letsencrypt_post_hook.sh:
    /usr/local/bin/letsencrypt_post_hook.sh: line 31: syntax error near unexpected token `;'
    /usr/local/bin/letsencrypt_post_hook.sh: line 31: `    else; if [ rpm -q ufw ]; then ufw --force enable && ufw deny http; fi'
    
    Symlink ISPConfig SSL certs to Postfix? (y,n) [y]: y
    
    Configuring DBServer
    Installing ISPConfig crontab
    Installing ISPConfig crontab
    no crontab for root
    no crontab for getmail
    Detect IP addresses
    Restarting services ...
    Installation completed.
    This is a 3.2 installation on a new server running Debian 10.
    Is there a bug regarding this as I'm not sure if there is any related in gitlab.

    Thanks
     
  2. Stelios

    Stelios Member HowtoForge Supporter

    Just found the relevant bug in gitlab and applied the patch; all is good now.
     
    ahrasis and Th0m like this.

Share This Page