LE SSL cert installed: 403 Forbidden

Discussion in 'General' started by schwim, Mar 26, 2018.

  1. schwim

    schwim New Member

    Hi there everyone!

    I followed this tutorial to install a Let's Encrypt SSL cert for a domain on my server. When I visit the domain, the browser shows that it is properly installed but the website returns a 403 forbidden instead of allowing me access to the pages on the site. If I change https to http in the URL, the page is served correctly.

    Can I ask what else I need to do to get the site to serve pages over the secure connection?

    Thanks for your time!
     
    Last edited: Mar 26, 2018
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    With site you mean the ispconfig login on port 8080? because the tutorial you followed is not for installing a letsencrypt ssl cert on a website, it is for securing the ISPConfig login, mail and ftp service.
     
  3. schwim

    schwim New Member

    Hi there and thanks very much for your help!

    I mean a normal website on the server. I'm fine with a self-signed on the ISPConfig panel.

    Is there a tutorial for installing the cert to be used on a website? I tried to enable it in the settings, which resulted in the error above. Prior to that, I tried to use SSL For Free, which also failed because it couldn't write to the user's FTP root. I'm really striking out with figuring out how to do this.

    Thanks for your time!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    To enable and create a Let's encrypt SSL cert for a website, all you have to do is to tick the 'Lets encrypt' checkbox in the website settings and press save. Maybe there was some config left from your attempt of using SSL for Free and this blocks letsencrpt now.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. schwim

    schwim New Member

    Thanks again for your help! The issue was my fault as I had accidentally renamed the index file. Once I restored it, the page displayed properly.

    Thanks for your help!
     

Share This Page