LDAP SuSE 10.1

Discussion in 'Server Operation' started by AboGassir, Dec 10, 2006.

  1. AboGassir

    AboGassir New Member

    Hi to all;

    I want to install an LDAP server along with a file server on a SuSE 10.1 machine. Actually, I googled for LDAP and found one useful article that made a good walkthrough:


    I struggled a bit to make it work for me, but finally I could make my LDAP work. I tested the configuration to see if it's working, I made that by trying to log a windows machine through my server, and it worked. But when authunticating the windows machine, it refered to that It can't find my profile, and by the way, I could only log in with the Administrator account "root". I also get concered about the roles and users policies and groups, I don't know ho to assign a user to a certain windows group? I mean how to apply a certain policy to a certain user? Is that possible? Where to create the policy? Where are the users' profiles are stored? ....? ......? .....etc.....

    So, I thinked about a GUI tool to configure the LDAP server, I googled alot and finally found NetDirector, which a web application that manages servers, I installed it and it's LDAP plugin also, thinking that I will go in a GUI way to configure my already UP server. But, when I try to configure the LDAP, it asks me for " Ldap Server Root(include absolute path) " and " Main Configuration File(include path relative to serverRoot) ", which actually I don't know.

    Before I got NetDirector, I downloaded many tools, but most of them were just LDAP browsers but not editors, and the rest I couldn't install.

    I aplogize for being too descriptive, but I tried to make my self clear as much as I can.

    I hope to find a solution to my case here, as I was looking to overcome this problem for over than a week!.

    Thanx in advance.:)
  2. budianto

    budianto New Member

    For your problem which the windows can only log in as 'root'. It's because you haven't add user. You only add machine.
    You can add user with the same command with add machine but use different type.
    If i am not wrong, you add machine using "smbldap-useradd -w" right??
    So you add user using "smbldap-useradd -m".
    After you add user, you must login to windows as 'root' like you experience just now, and in control panel, create new user account there, the same with the user name you just create in linux.
    Restart windows and try the new user account you have made.

    You can't find your profile because you use root and you haven't declare profile for root. it doesn't matter but your new user account won't face this error.

    certain policy for group or user can be declare at smb.conf. Find any information about user and security configuration for samba in internet.

    I never use Ldap in GUI model. If you success please share your experience ;D
  3. budianto

    budianto New Member

    your profile error, it's because there is small error in http://en.opensuse.org/Howto_setup_S...1_as_Samba_PDC.

    In giving samba permission to create roaming profile directories, it's written "# chmod 1777 /var/lib/samba/profiles".
    The right one is "# chmod 777 /var/lib/samba/profiles".

    777 means can be read, written, and execute by user, group, and other

Share This Page