latest installation failed, php binary error. no thread answers this one...

Discussion in 'Installation/Configuration' started by crypted, May 25, 2007.

  1. crypted

    crypted New Member

    ***************************************************************************
    NOTE: the optional Encode::Detect module is not installed.

    If you plan to use the normalize_charset config setting to detect
    charsets and convert them into Unicode, you will need to install
    this module.

    REQUIRED module out of date: HTML::parser
    optional module missing: Mail::SPF
    optional module missing: Mail::SPF::Query
    optional module missing: IP::Country
    optional module missing: Razor2
    optional module missing: Net::Ident
    optional module missing: IO::Socket::INET6
    optional module missing: IO::Socket::SSL
    optional module missing: Compress::Zlib
    optional module missing: Time::HiRes
    optional module missing: Mail::DomainKeys
    optional module missing: Mail::DKIM
    optional module missing: Encode::Detect

    warning: some functionality may not be available,
    please read the above report before continuing!

    ERROR: Could not configure SpamAssassin
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    [email protected]:~/install_ispconfig#


    [email protected]:~/install_ispconfig# uname -a
    Linux its.inter5.org 2.6.9-42.0.10.EL #1 Tue Feb 27 09:24:42 EST 2007 i686 i686 i386 GNU/Linux
    [email protected]:~/install_ispconfig# free
    total used free shared buffers cached
    Mem: 1027552 442308 585244 0 71128 227560
    -/+ buffers/cache: 143620 883932
    Swap: 1012084 0 1012084
    [email protected]:~/install_ispconfig#

    Installed Packages:
    mysql-devel-4.1.20-2.RHEL4.1
    mysql-4.1.20-2.RHEL4.1
    mysql-server-4.1.20-2.RHEL4.1
    php-mysql-4.3.9-3.22.5
    php-gd-4.3.9-3.22.5
    php-mysql-4.3.9-3.22.5
    php-odbc-4.3.9-3.22.5
    php-pear-4.3.9-3.22.5
    php-ldap-4.3.9-3.22.5
    php-4.3.9-3.22.5
    php-xmlrpc-4.3.9-3.22.5
    php-devel-4.3.9-3.22.5
    php-imap-4.3.9-3.22.5
    xmlsec1-openssl-1.2.6-3
    openssl-0.9.7a-43.16
    openssl-devel-0.9.7a-43.16
    httpd-suexec-2.0.52-32.ent.centos4
    httpd-2.0.52-32.ent.centos4

    I've done the ZLIB trials and all the other little details in ERROR: The Php Binary coming with... thread, no success. I even tried reverting to the old installation I was upgrading from and it wouldn't upgrade now. The previous versions installer tells me my OS (Centos4.4) isn't detected. Both installers now are saying I have (Centos4.5)... What do I do to get this thing working???
     
  2. crypted

    crypted New Member

    i solve this portion of the problem and got to the mysql part but i quit out because i went to /var/db/ to find out the DB name of the old ISPCONFIG installation and there are NO MORE DBS!!! they are entirely gone!!!!!! how did this update kill off all my data?
     
  3. crypted

    crypted New Member

    Okay forget it, I drank a lot of coffee and fixed it all... LESSON ONE: do not do things when very tired
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Just as hint for everyone who finds this Thread:

    The error message above contains the hint what has gone wrong:

    Thie problem affects only CentOS and there only versions < 5.0 and the solution is described in the Release notes of ISPConfig 2.2.13 and has been added to the perfect setup guides:

     

Share This Page