LAMP working *almost* perfectly on Debian Etch

Discussion in 'Installation/Configuration' started by sigsegv, Jun 27, 2007.

  1. sigsegv

    sigsegv New Member

    Hi all,

    I followed the absolutely excellent tutorial here:

    It took me only about an hour and it is working just great!

    Having followed all 7 pages of instructions, I have encountered only two errors:

    (1) -- On page 3 - quotacheck -avugm returns the error "quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option."

    (2) -- When I run PHP from the command line, I get a warning message: "PHP Warning: Module 'json' already loaded in Unknown on line 0"

    Other than that it all seems to be working just fine!

    I wonder if anyone has any idea as to what might be causing these errors.


  2. falko

    falko Super Moderator ISPConfig Developer

    Did you modify /etc/fstab and remount the filesystem as shown in the tutorial?

    Sounds like the json module is loaded twice in php.ini and its included files. Can you check php.ini and the files that are included in php.ini?
  3. sigsegv

    sigsegv New Member

    Hi Falko,

    Thanks for the tutorial!

    Ok, I fixed the PHP problem by commenting out the line including the json module in php.ini. Incidentally, the PHP docuementation states that json is bundled with php 5.2, so am I correct in assuming that the explicit php-json reference is no longer required in the apt-get for php5 in your tutorial?

    I checked what I'd done regarding the remounting and yes, I have edited my /etc/fstab as shown and I remounted the filesystem as instructed. I still get the error. In addition, when I boot the machine I get the error report mounting local filesystems: mount point 0 does not exist ... failed. However the system starts up and runs just fine (?!).

    The output of mount -l is as follows:

    tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    procbususb on /proc/bus/usb type usbfs (rw)
    udev on /dev type tmpfs (rw,mode=0755)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
    rootfs on / type rootfs (rw)

    so the filesystem is mounted .... but not locally? Via LO? I'm not sure!

    Thanks again,

    Last edited: Jul 1, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/fstab?
    Where did you create the quota.user and files?
  5. sigsegv

    sigsegv New Member

    Hi falko.

    My fstab looks like this:

    # /etc/fstab: static file system information.
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hda1 / ext3
    defaults,errors=remount-ro,usrquota,grpquota 0 1
    /dev/hda5 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

    Incidentally, the newline between "ext3" on the second line and "defaults,..." really is there in my fstab ... I have deleted it twice but when I reboot the system, there it is again!

    My quota.user and files are in the filesystem root "/" as instructed.


  6. falko

    falko Super Moderator ISPConfig Developer

    Are you absolutely sure you have saved the modifications?
  7. sigsegv

    sigsegv New Member

    Hi Falko,

    Yep, saved the modifications! Tried a reboot, there the mysterious newline was again ... then apt-get'ed xemacs and modified the file using that particular editor (I've slapped an XWindows font-end onto the server), saved it, no problems! quotacheck works fine, filesystem mounts fine, WTF??? :confused: :confused: :confused: Lol!

    Thanks a lot for your help,

  8. falko

    falko Super Moderator ISPConfig Developer

    And how does /etc/fstab look like after you've changed it and before you reboot?

Share This Page