LAMP on suse 10.2 error

Discussion in 'Installation/Configuration' started by madmac007, Feb 15, 2007.

  1. madmac007

    madmac007 New Member

    following Falko`s how to at http://www.howtoforge.com/perfect_setup_opensuse_10.2

    on page 7 half way down the page ,when we have to start apache I get this error:

    SuSEconfig
    /etc/init.d/apache2 start
    Starting httpd2 (prefork) Syntax error on line 11 of /etc/apache2/mod_log_config.conf:
    Invalid command 'LogFormat', perhaps misspelled or defined by a module not included in the server configuration

    The command line was:
    /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL

    Any help would be great
    Thanks
    MadMac
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in the APACHE_MODULES line in /etc/sysconfig/apache2? I hope you didn't copy the [...] into your file. I've just put it into the tutorial because otherwise the line would have become too long.
     
  3. madmac007

    madmac007 New Member

    apache2 file

    in the /etc/sysconfig/apache2

    APACHE_MODULES="actions alias auth_basic authn_file setenvif ssl suexec userdir php5 rewrite"


    Thanks for the reply Falko

    Hope this info help us to find the issue

    MadMac
     
  4. madmac007

    madmac007 New Member

    Rtfm

    ach schitza

    It pays to read and read again.
    my /etc/sysconfig/apache2 file now reads as it should:

    APACHE_MODULES="actions alias auth_basic authn_file authz_host authz_groupfile authz_default authz_user authn_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir php5 rewrite"

    I then restarted apache and it worked.

    I guess i should have RTFM correctly , I can now continue the install.

    Thanks again Falko

    amadaeus rocks

    MadMac
     

Share This Page