Kvm networking

Discussion in 'Installation/Configuration' started by ripit, Jun 12, 2009.

  1. ripit

    ripit New Member

    Hi

    I'm running kvm on ubuntu 9.04 and I can't get networking to work when I start as user and not root. If I add user to group libvirtd it works. I have a setup with a bridge and I would like for the user to start their own vm either by virsh ot virt-manager.

    If I run it with:

    virsh --connect qemu:///system

    as root or if the user is a member of libvirtd it works but i would like it run it like this:

    virsh --connect qemu:///session

    so that the user can setup and run its own vm from his home catalog.
    When i run it as user and connect to session then I'm not allowed to connect to br0, that is my bridge.

    Because everything works fine when I'm root I think it has something to do with setting the rights, but I don't know where to look.

    If someone has any suggestions I would be very happy.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    As far as I know, you must add the user to the libvirtd group.
     
  3. ripit

    ripit New Member

    Yepp that's the problem. I would like each user to be able to run their own vm. If I add them to libvirtd they still can't run vms from their home directory. It must be someway to run a vm from the user dir with network functioning some setting file that I havae missed.
     

Share This Page