Kubuntu 7.04 Kmail TLS/PLAIN SASL error

Discussion in 'Installation/Configuration' started by just.another.alex, Sep 28, 2007.

  1. just.another.alex

    just.another.alex New Member

    Hello to all!
    Here is my problem:
    I can't send e-mails from my Kubuntu 7.04 desktop PC, using Kmail e-mail client. When i push "Send button", following Kontact error appears:

    "Sending failed:
    Authorization failed, An error occured during authentication: SASL(-4): no mechanism available: No worthy mechs found authentication not supported
    The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
    The following transport protocol was used:
    send_smtp"
    ...and the mail is not send!

    The "security settings" for my mail send account are:
    Encryption: TLS
    Authentication Method: Plain

    Important details about this issue:

    1) This e-mail sending error appears only when I'm authenticate against LDAP server (the network I'm in has NFS-mounted home dirs and LDAP authetication). When I use a local user (or root user), everything works right!

    2) This error appears only in Kubuntu 7.04. I know this because I tested the same system configuration settings(including LDAP auth enabled) in Kubuntu 6.06 + kmail and the mail-sending worked just FINE!

    If anybody had this problem after upgrading/replacing 6.06 -> 7.04, or know smthing about it, please let me know(i googled awhile, but no relevant results for me) !!!

    PS: I can give more details about my config, just ask me :)
    Thanks in advance!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/postfix/sasl/smtpd.conf?
     
  3. just.another.alex

    just.another.alex New Member

    On my mail server, I have Kolab package installed, so I guess the path you asked me about is in my case /kolab/etc/sasl/apps/smtpd.conf. The smtpd.conf is a 2 line file and contains:
    pwcheck_method: saslauthd
    mech_list: PLAIN LOGIN
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is there no /etc/postfix/sasl/smtpd.conf? It should contain
    Code:
    pwcheck_method: saslauthd
    mech_list: PLAIN LOGIN
    as well.
     
  5. just.another.alex

    just.another.alex New Member

    I added the file /etc/postfix/sasl/smtpd.conf on my mail server. The file contains:
    Code:
    pwcheck_method: saslauthd
    mech_list: PLAIN LOGIN
    After adding the file, I restarted the kolab service, and then try to send the emails.
    The error remains the same! (Authorization failed, An error occured during authentication: SASL(-4): no mechanism available: No worthy mechs found authentication not supported....)

    After trying this, I also added a smtpd.conf file(contents is the same as above), in
    /kolab/etc/postfix/sasl, restarting mailserver, and tried again...Error again! :((

    What could this be? If any other infos would be useful, just ask them...
    (This mailsend problem tends to become a painintheass)...
     
  6. just.another.alex

    just.another.alex New Member

    Kubuntu 7.04 Kmail TLS/PLAIN Problem SOLVED!!!

    Hello Again!
    The problem I posted above is solved now!
    The solution was an upgrade to Kubuntu 7.10 Release!
    I downloaded the ISO image from:
    http://kubuntu.org/announcements/7.10-release.php

    After a fresh install, I configured LDAP as I did on Kubuntu 6.06, then configured kmail as usual, aanndd....VICTORY!
    No more error at mail sending!
    So, if any of you had this problem, the solution is an installation of Kubuntu 7.10!

    It's somehow logic that an upgrade was the solution, because, as I already said, the kmail/ldap/sasl configuration worked in Kubuntu 6.06...
    It's sad that at least two versions(maybe more, I give here the ones I've installed and tried) after the 6.06 (i'm talkin' about 7.04 and 7.10 beta) lack the kmail/ldap /sasl mail sending feature. This can cause a lot of confusion.
    Anyway, Kubuntu 7.10 saved my day! :D
     

Share This Page