kmod-nvidia stopped working

Discussion in 'Technical' started by dpicella, Aug 29, 2009.

  1. dpicella

    dpicella New Member

    I've got a fairly new desktop system.

    Installed Fedora 11 and kmod-nvidia. Everything was working, but suddenly my programs are complaining that my hardware does not support 3D acceleration.

    I've removed and reinstalled the kmod-nvidia packages but still have the same result.

    I can't enable Compiz either.

    Really don't know how to troubleshoot this. I've come across everything from bugs to repo updates that are not in full sync with my kernel yet.

    Any ideas?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Was it working before?
    Is this your only graphics card, or is there maybe another one (maybe integrated on the mainboard)?
     
  3. dpicella

    dpicella New Member

    kmod-nvidia not working fedora 11

    Yes, it was working ... it just stopped. The computer works just fine, I just can't activate the 3D graphics acceleration.

    My kids use this particular computer too so it could have been something they did, but they don't have root's password to make any sys modifications.

    I am going to check the motherboard ... good idea. I might also just re-seat the graphics card just in case.

    Thanks!
     
  4. dpicella

    dpicella New Member

    1. Not in the motherboard settings
    2. Reseated the graphics card

    Still the same problem

    I removed kmod-nvidia using:

    yum remove *nvidia\*

    On reinstall ... I get the following error:

    I think the kernel must have been updated on one of my sys updates and the rpmfusion-free repo is just not up to date yet.

    ???
     
  5. dpicella

    dpicella New Member

    I figured it out. It's working again.

    At some point I must have upgraded my system using the Fedroa Testing Updates repos.

    I don't recommend this.

    I also don't recommend using the rawhide repos - those can really hose your system if you are not careful.

    The problem with using testing repos is that it will put you ahead of the game with other programs that you might want to install. For example, I could not install wine as one of the dependencies was newer that what was expected. I also have a need to use ies4linux to test some websites but can't quite get that working yet for the same reason.

    I guess the moral of the story is not to be so eager to update or this is the situation you may find yourself in.

    BTW ... I also had to uninstall and reinstall the rpmfusion repos and to make sure that the baseurl lin in the .repos in /etc/yum.repos.d/ where not commented out.
     

Share This Page