Kind help sought: FC11 booting to blank screen after upgrade from fc10

Discussion in 'Installation/Configuration' started by cbalaji, Jul 15, 2009.

  1. cbalaji

    cbalaji New Member


    I was working with FC10. Whenever I reboot, automatic updates are performed. Recently an option to upgrade FC10 to FC11 appeared automatically (similar to the second screen shot given at ). Because this appeared automatically I didnt get a chance to perform the command line statements that were given at the same site (especially, yum clean all, I dont know if that is the problem). Except for these commands everything followed similar to the way explained in the web page .

    During reboot the upgrade was performed. However, I am not able to successfully get into the FC11 desktop. When booted with FC11 (I also have windows xp), the system enters to a blank screen. Did some search in the internet, however I was not able to get to the thread that addresses this problem. Some of the suggestions given were to append 3 or 1 in the kernal parameter, however this was not helping, again the system enters to a blank screen and whatever I write using the keyboard appears on the screen. I am sure that this blank screen is not a shell.

    I request the users to kindly give their suggestions and help me overcome this problem.

    C. Balaji
  2. fiveable

    fiveable New Member

    Same exact problem here.

    I have the same problem. Upgraded via DVD from 8 to 9 with no problem. Then went from 9 to 10 and the problem started. At first I thought it was a problem with the nvidia driver so I switched to the second console screen and tried rebuilding the driver using the nvidia command line utility. Even as root the process faild and I did not have permission to run things like "shutdown -h now".

    The blank screen behaves this way. After the last script in rc5.d runs the screen flashes rapidly quite a few times and drops to a black screen with blinking rectangle cursor. You can move the cursor with the mouse. You can highlight parts of the screen with the mouse. I agree with the previous post that this is not a shell. It is possible to type characters but CtrlC,CtrlD,CtrlZ have no effect.

    Has anyone seen this before???:(
  3. fiveable

    fiveable New Member

    Additional info...

    I went ahead and upgraded further from Fedora (x86_64) 10 to 11 via DVD with the hope that some updates would resolve the problem. After "successfully upgrading" to Fedora 11 the problem still exists.
  4. fiveable

    fiveable New Member


    Ok, as it turns out this problem is an X problem.

    Simply move the xorg.conf file to xorg.conf.bak and reboot.

    From the blank screen I did the following and it worked:

    Alt-F2 (to switch to the second console screen)

    login as root

    cd /etc/X11

    mv xorg.conf xorg.conf.20090716

    ctrl-alt-del to reboot

  5. cbalaji

    cbalaji New Member

    Hai Fiveable,
    As I was in urgent need, I went for an fresh install to FC11 and it went on smoothly without problem . Sorry, I could not get an opportunity to try your suggestion.
    C. Balaji
  6. antonio148

    antonio148 New Member

    worked for me

    thank you
    you just saved my weekend

Share This Page