Kernel Panic - not syncing FC4

Discussion in 'Kernel Questions' started by ACDII, Aug 12, 2008.

  1. ACDII

    ACDII Member

    I have a Dell 2650 that has been running Fedora Core 4 OK for over two years, but occasionally the raid errors and locks the drives to read only so the only recovery is to power cycle it. Well the last power cycle broke something, and now it is stuck at kernel panic.

    The jist of it is,

    EXT3-fs error ext3_get_inode_loc: unable to read inode block

    ERROR opening /dev/console!!!!:5
    error dup2'ing fd of 0 to 0 (etc)

    then the EXT3 three more times, then finally before the panic

    WARNING: can't access (null)

    I need to recover the databases off this server, but not the OS or APPs, I have some MySQL databases I must have off of this, so how can I get them off without destroying them? I cant seem to find an FC4 recovery disk.

    I am downloading KNOPPIX as I read I can boot off that CD and access the drives and move the files to a USB drive, but it would be nice to be able to boot the actual system up to recover everything.
    Last edited: Aug 12, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

  3. ACDII

    ACDII Member

    I found the problem after getting ansty waiting for the download. I ran the SCSI disk utility and found 3 bad sectors and had them remapped, then the server booted to the point where it got to the bad sectors and went into repair mode. I ran fsck and it fixed the bad files in those sectors, so now the system is bad in operation, but out of service, I moved all the important stuff to a different server. Whew, that saved a whole load of time trying to reload all the IP information that was stored on that server database.

Share This Page