keep getting 404 error with ISPconfig webmail

Discussion in 'General' started by Heeter, Jul 6, 2009.

  1. Heeter

    Heeter Member HowtoForge Supporter

    Hi all,

    I am trying to figure out why I keep getting 404 error when I type in my domain address ""

    This is both inside and outside the network. When I type in the IP address inside the network "" squirrelmail does come up.

    This is for ISPConfig3/Debian5


    Last edited: Mar 7, 2011
  2. Rescue9

    Rescue9 ISPConfig Developer ISPConfig Developer

    REMOVED: I didn't properly read the question. My answer was in error.
    Last edited: Jul 6, 2009
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats easy as you can not connect to webmail trough the domain as there is no directory named webmail in the website You can either make a symlink inside the website directory that points to the sources of the webmail application (works only for mod_php oe cgi /fcgi php without suexec) or you create a nwe website like and install a webmail client of your choice in it.
  4. Heeter

    Heeter Member HowtoForge Supporter

    Hi Till,

    How does the domain go about answering email from outside the network without installing their own webmail?

    Will a package be made available to install like ISPConfig2?

    Thanks again,

    Jaguar xjr-15 history
    Last edited: Mar 7, 2011
  5. Mark_NL

    Mark_NL New Member

    Can' you just add an Alias + some directory directives to you apache2.conf
    did that and works fine on all domains, patched roundcube so it autom. picks up the correct domain for initial user setup .. et voila
  6. Heeter

    Heeter Member HowtoForge Supporter

    Great Idea, MarkNL

    Wold you be able to give a little more detail on that setup? That would be much appreciated.


    Ultimate fighter
    Last edited: Mar 7, 2011
  7. Mark_NL

    Mark_NL New Member

    I wanted all new and existing customers have:

    So i installed phpmyadmin and roundcube in /var/www/sharedip (this way it's also reachable through http://serverip/...


    (i put _ infront to distinguish normal folders from alias-ed dirs)

    - Make a extra.conf in /etc/apache2
    Alias /phpmyadmin/ /var/www/sharedip/_phpmyadmin/
    Alias /webmail/ /var/www/sharedip/_webmail/
    <Directory "/var/www/sharedip/">
     AddType application/x-httpd-php .php
     AllowOverride Options Limit FileInfo
    The AllowOverride is there for roundcube to work correctly (with it's .htaccess)

    Add the following line at the END of your /etc/apache2/apache2.conf:
    Include /etc/apache2/extra.conf
    Now install roundcube as normal, just follow the instructions and use the test at the end to see if everything works.

    Now open and go to line 76. It should say:
    $rcmail_config['username_domain'] = '';
    change that to:

    preg_match('/.*?\.(.*)/', $_SERVER['SERVER_NAME'], $aMatches);
    $rcmail_config['username_domain'] = $aMatches[1];
    It's probably not watertight, but it works :)

Share This Page