Just trying to install

Discussion in 'Installation/Configuration' started by Roger Huston, Jan 17, 2007.

  1. Roger Huston

    Roger Huston New Member


    Obviously, I am a new Linux user. I have been struggling for the past two weeks to try and setup a LAMP system using Fedora Core 6. I followed the tutorial on this board (except I am using DHCP instead of a static IP) and got through the first steps just fine.

    Next I tried installing ISPConfig and the first time it went through it got to the mysql part and it would not recognize my root password. Kept coming back and saying [email protected] not valid.

    I went on the internet and searched for ways to redo it. I can get into mysql using mysql -u root -p on the command line just fine.

    Now I have tried to rerun the IPConfig installer and it blows up at the same place:

    All prerequisites are fulfilled.
    Here we go....

    Warning: include(config.inc.php): failed to open stream: No such file or directory ih /usr/local/src/install_ispconfig/install.php on line 665.

    Then a couple more warnings one of them again mysql_connect(): Access denied for user 'root' @ 'localhost' (usihg password: NO)

    Now, here is the strange part. I am installing from /usr/local/src and when I try and go back to the ipconfig_install directory there, nothing exists! It is like half way through the installer it deleted the entire install directory. I never get as far as trying to type in my mysql info again.

    I am wondering what to do. I spent most of the day installing the OS (yum update). Should I try removing mysql and reinstalling?

    - Roger
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    If the setup process of ISPConfig 'breaks', terminates with an error or similar, the setup will clean (wipe-out) the install directory. The developers did this on purpose, so did I understand.

    If ISPConfig setup crashes, remove the directories /root/ispconfig and /var/www/admispconfig (the latter if you did not do expert mode install - and did not use another name for /var/www default) and remove manually the database. There are many threads here describing the precise commands. Then extract the .tar again and start from scratch.
  3. Roger Huston

    Roger Huston New Member

    Thank you for taking the time to post. I know how to remove the directories and I will search for the command to drop the database.

    - Roger
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    An easy wa to drop the database is by deeleting the database directory. Go to /var/lib/mysql/, there must be a directory with the name of your database. If you delete this directory, your database is removed.

    (I know that you can do it with mysql commands too, but deleting the directory is faster :D
  5. Roger Huston

    Roger Huston New Member

    I figured it out. During my installation I used some [email protected]# characters in my MySQL password. While it allows me to login using mysql - u root -p and typing the password in the line, when used in scripts I get a command line substitution that will break the script.

    This is easy to see, when you enter your mysql password on the command line using mysql -u root -pZAQ!2wsx for example. Hit the up arrow to see if the password is the same in your history. If not, you have a problem.

    Once I was able to change the root password using [A-Z][a-z][0-9] characters only, the install went perfectly.

    It would be nice if in the instructions for MySQL installation that someone should mention this limitation so new people like me won't have such a hard time.

  6. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Can't hurt to repeat this warning. I know there are 'at least' 5 threads with this warning recently. :)
  7. Roger Huston

    Roger Huston New Member

    Well, I checked through the first 5 pages before posting, I couldn't find anything. Maybe someone could update the "How To" guide at the MySQL point. I am sure that would save a lot of newbie type of questions.

    - Roger

Share This Page