Just ran the most current of ISP3

Discussion in 'Installation/Configuration' started by happz, Feb 14, 2012.

  1. happz

    happz Member

    It ran fine as it has in the past when I've done this. Then, after about 10 mins afterwards, I went to set a site to run an auto back through the ISP system. It locked up. I waited a minute and then rebooted the server.

    Now, nothing will load. I can't log in to isp nor will any site come up.

    How to restore.. I found a backup in /var/backup

    thanks for any help

    happz
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There should be no need to restore the server from a backup. Instead you should restart apache, if it dont start, post the errors that you got on the shell ind in the apache error.log.
     
  3. happz

    happz Member

    Here's my message when restarting apache:

    Syntax error on line 110 of /etc/apache2/sites-enabled/100-linkjox.com.vhost:
    Invalid command 'session.save_path=/tmp', perhaps misspelled or defined by a module not included in the server configuration

    What I did after the ispconfg3 upgrade was to replace a domain because I wasn't going to use it. I renamed it in the admin panel and I've done this many times before. The new domain is the one listed as having an error on line 110.

    This is the last few lines in /var/log/apache2/error.log

    Code:
    [Mon Feb 13 19:14:38 2012] [notice] caught SIGTERM, shutting down
    [Mon Feb 13 19:14:39 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Feb 13 19:14:39 2012] [notice] Digest: generating secret for digest authentication ...
    [Mon Feb 13 19:14:39 2012] [notice] Digest: done
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imagick.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/mcrypt.ini on line 1 in Unknown on line 0
    [Mon Feb 13 19:14:39 2012] [notice] Apache/2.2.14 (Ubuntu) DAV/2 mod_fcgid/2.3.4 PHP/5.3.2-1ubuntu4.9 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-01-10) mod_ssl/2.2.14 OpenSSL/0.9.8k configured -- resuming normal operations
    [Mon Feb 13 19:15:07 2012] [error] [client 66.249.67.244] File does not exist: /var/www/profile-2
    [Mon Feb 13 19:17:36 2012] [error] [client 66.249.67.244] File does not exist: /var/www/blog
    [Mon Feb 13 19:17:38 2012] [error] [client 66.249.68.104] File does not exist: /var/www/robots.txt
    [Mon Feb 13 19:19:22 2012] [error] [client 66.249.67.244] File does not exist: /var/www/apps/category
    [Mon Feb 13 19:23:06 2012] [notice] caught SIGTERM, shutting down
    [Mon Feb 13 19:23:07 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Feb 13 19:23:07 2012] [notice] Digest: generating secret for digest authentication ...
    [Mon Feb 13 19:23:07 2012] [notice] Digest: done
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imagick.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imap.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/mcrypt.ini on line 1 in Unknown on line 0
    [Mon Feb 13 19:23:07 2012] [notice] Apache/2.2.14 (Ubuntu) DAV/2 mod_fcgid/2.3.4 PHP/5.3.2-1ubuntu4.9 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-01-10) mod_ssl/2.2.14 OpenSSL/0.9.8k configured -- resuming normal operations
    [Mon Feb 13 19:23:09 2012] [notice] caught SIGTERM, shutting down
    

    thanks,
    happz
     
    Last edited: Feb 14, 2012
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if the error is related to domain settings and not the update. To fix it:

    1) Edit the file /etc/apache2/sites-enabled/100-linkjox.com.vhost and delete the line that start with session.save_path.
    2) Start apache.
    3) Login to ispconfig, edit the settings of the domain linkjox.com and remove the line session.save_path from the apache directives field.
     
  5. happz

    happz Member

    Done! Thanks Till. That fixed the issue. Now I have to ask you this:

    I ran a tar xvfz on two files in /var/backup

    Code:
    etc  etc.tar.gz  ispconfig_db_backup.sql  ispconfig_software.tar.gz  usr
    [email protected]:/var/backup/ispconfig_2012-02-13_19-13#
    
    It looks like it only unpacked it to the backup folder but I just want to check.

    Thanks
    Randy
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If you did not move the unpacked files to another dircetory, then everything is ok. You should delete the unpacked backup.
     

Share This Page