Just installed squirrelmail package, but can't logging?

Discussion in 'Installation/Configuration' started by jnolla, Jun 3, 2007.

  1. jnolla

    jnolla New Member

    Just installed squirrelmail package, but can't logging?

    I get the following message:
    Unknown user or password incorrect.

    I've tried both email addresses and user logins, but not luck. I really don't know what to do next.

    Please Help,
    Best Regards
  2. edge

    edge Active Member Moderator

    Did you install it from the "Third-Party Tools & Add-ons" (the .pkg package)?
  3. jnolla

    jnolla New Member

    Yes I did. I installed the zipped package from ispconfig.org. Squirrelmail shows up at www.example.com:81/squirrelmail, and I can also click on the link under tools.
  4. jnolla

    jnolla New Member

    For some reason when enter:
    telnet localhost 25

    I don't get anything at all, it just stalls!
    Don't know if it is related
  5. jnolla

    jnolla New Member

    This the error taken from the maillog:

    Jun 3 17:06:25 server dovecot: imap-login: Aborted login: user=<[email protected]>, method=PLAIN, rip=::ffff:, lip=::ffff:, secured

    I have not made any modifications to the system, and it automatically adds @example.com when I just enter 'admin'. This is still a valid email within ispconfig '[email protected]'

    I can't enter just the ispconfig username web1_admin, because it automatically adds @example.com

    Thanks again
    Last edited: Jun 3, 2007
  6. jnolla

    jnolla New Member

    Ok. I can logging using thunderbird to my POP account, though I've sent messages from a gmail account to it, and I have yet to received them!

    I don't know how to remove the @example.com from coming up on the user: slot when entered through squirrelmail. I believe this is the reason I'm not able to login through webmail.

    Now about postfix not working, and smtp not being accessible through thunderbird, still working on.

    If there is any help out there it's all welcomed here!
  7. jnolla

    jnolla New Member

    Here the error for postfix:

    server postfix/smtpd[15353]: fatal: open dictionary: expecting "type:name" form instead of "hash:"

    server postfix/master[25629]: warning: process /usr/libexec/postfix/smtpd pid 15353 exit status 1

    server postfix/master[25629]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

    Will try a reinstall of postfix in a bit
  8. jnolla

    jnolla New Member

    Got postfix working! I had to redo the file /etc/postfix/main.cf

    Instead of entering all of the paramaters throught the command line, I copied the example posted in the howtos.

    Dovecove still does no receive any email though I can login through thunderbird, and still have the problem with squirrelmail adding the @example.com, thus not allowing for the ispconfig username which is the one needed to login.

    Best Regards
  9. jnolla

    jnolla New Member

    After some more searching, found a plugin vhost already installed with the package from ispconfig. This made the @mywebsite.com be entered in the login user space. This would have been great if the installation of the package would allow all site hosted through ispconfig reach squirrelmail.

    In fact the only site that allows the squirrelmail through the actual installation of the package, is the ispconfig site https://www.mywebsite.com:81/squirrelmail.

    How do I fully take advantage of this package? I imagine I could make an alias of the directory squirrelmail, and inserted in each new site as they are created. Will this work?

    I still get no emails in the account created, though I can send.

    Best regards
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not correct. All sites can use squirrelmail through the main domain of the server. This is the way most ISP's use it.
  11. jnolla

    jnolla New Member

    Ye I can access i through the main site, but It automatically adds @example.com, this is because it has the vhost plugin.
  12. Jcorrea920

    Jcorrea920 New Member

    You may want to try a new plugin "virtusertable"

    ON 4th June 2007 04:25,
    jnolla said:
    I had the same problem. In the vlogin setup file the default domain is set at "example.com"
     less /home/adminispconfig/ispconfig/web/squirrelmail/plugins/vlogin/setup.php
    I was not going to bother experimenting with that setting since there are many users on many different domains. So I did something that will allow it to authenticate properly using information stored in /etc/postfix/virtusertable.
    sudo cd /home/admispconfig/ispconfig/web/squirrelmail/plugins/
    sudo wget http://www.squirrelmail.org/countdl.php?fileurl=http%3A%2F%2Fwww.squirrelmail.org%2Fplugins%2Fvirtusertable-0.3.tar.gz
    sudo tar xvf virtusertable-0.3.tar.gz
    sudo cd virtusertable
    sudo vim setup.php
    $filename = '/etc/mail/virtusertable';
    change to path/to/your/virtusertable file.
    $filename = '/etc/postfix/virtusertable';
    Save and close file. (Esc :x!)
    cd ..
    sudo chown -R admispconfig:admispconfig virtusertable/
    sudo ./config/conf.pl
    8. Select Plugins
    Install virtusertable plugin by typing the number associated with it.
    R (To return to Main Menu)
    11 (Tweaks)
    6. (Allow remote config test) = true    [you may change this back later]
    Save and Quit
    sudo chown root:admispconfig /etc/postfix/virtusertable*
    sudo chmod 640 /etc/postfix/virtusertable*
    On your browser go to https://yourserverdomain.com:81/squirrelmail/src/configtest.php

    Read the output it will tell you if there are any problems with squirrellmail.
    If all is OK
    You should be able to login using the information in virtusertable. ISPConfig is designed to use this file to match usernames with full emails including aliases.

    Good Luck!

Share This Page