joomla template problem or is it.

Discussion in 'Installation/Configuration' started by shajazzi, Mar 10, 2007.

  1. shajazzi

    shajazzi Member

    I have been running a server using suse9.3 and php5 for some time which has been running fine.
    Then i decided to set up another server with Suse 10.0 rather than 9.3 because the 9.3 disc no longer works.
    I installed suse 10.0 via the perfect setup then install ispconfig and all went well.
    Then i install a test site with joomla 1.0.11 Stable.
    The default templates that come withh joomla all run fine .
    When i load other template such as bonq_nature, it installs fine but when i look at the the front end all the content items are not displaying and i also get these errors:



    Warning: main(mainbody.php): failed to open stream: No such file or directory in /srv/www/web1/web/templates/bonq_nature/index.php on line 79

    Warning: main(): Failed opening 'mainbody.php' for inclusion (include_path='/usr/share/php') in /srv/www/web1/web/templates/bonq_nature/index.php on line 79

    Warning: main(pathway.php): failed to open stream: No such file or directory in /srv/www/web1/web/templates/bonq_nature/index.php on line 29

    Warning: main(): Failed opening 'pathway.php' for inclusion (include_path='/usr/share/php') in /srv/www/web1/web/templates/bonq_nature/index.php on line 29

    This is some of the error log

    [Thu Mar 08 23:30:21 2007] [error] an unknown filter was not added: PHP
    [Thu Mar 08 23:30:21 2007] [error] an unknown filter was not added: PHP
    [Thu Mar 08 23:30:23 2007] [error] an unknown filter was not added: PHP
    [Thu Mar 08 23:30:23 2007] [error] an unknown filter was not added: PHP
    [Thu Mar 08 23:30:25 2007] [error] an unknown filter was not added: PHP
    [Thu Mar 08 23:30:25 2007] [error] an unknown filter was not added: PHP
    [Thu Mar 08 23:46:08 2007] [notice] Graceful restart requested, doing restart
    [Thu Mar 08 23:46:09 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Thu Mar 08 23:46:09 2007] [warn] long lost child came home! (pid 31046)
    [Fri Mar 09 06:17:18 2007] [notice] caught SIGTERM, shutting down
    [Fri Mar 09 06:22:40 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Fri Mar 09 06:22:45 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Fri Mar 09 06:42:15 2007] [notice] caught SIGTERM, shutting down
    [Fri Mar 09 22:32:07 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Fri Mar 09 22:32:11 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Fri Mar 09 22:45:08 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 14:58:05 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Mar 10 14:58:09 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 15:17:44 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 15:17:45 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Mar 10 15:17:46 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 15:23:22 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 15:23:23 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Mar 10 15:23:23 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 15:25:21 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 15:25:22 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Mar 10 15:25:22 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 15:36:58 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 15:36:59 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Mar 10 15:36:59 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 15:41:44 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 15:41:44 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Mar 10 15:41:45 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 15:44:22 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 15:44:23 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sat Mar 10 15:44:23 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 16:12:58 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 16:28:07 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib64/php/extensions/swf.so' - /usr/lib64/php/extensions/swf.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [Sat Mar 10 16:28:07 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sat Mar 10 17:24:51 2007] [notice] caught SIGTERM, shutting down
    [Sat Mar 10 17:24:52 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib64/php/extensions/swf.so' - /usr/lib64/php/extensions/swf.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [Sat Mar 10 17:24:52 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations

    I have also tried to install suse10.1 and 10.2 and i am still getting the same results
    I have searched all the joomla forums but with no joy.
    I think that maybe this is a php problem and not a joomla problem

    Any help PLEASE

    shajazzi.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Take a look here: http://www.howtoforge.com/forums/showthread.php?t=4770&highlight=$go_info["server"]["apache2_php"]
     
  3. shajazzi

    shajazzi Member

    Thanks for the response falko,

    I did as you sugested and this seemed to solve the error log problem, however i am still getting the same errors on the front page of my site, also the content is still missing.
    I also set post data size in php,ini to a higher value 16 M
    These are the errors:

    Warning: main(mainbody.php) [function.main]: failed to open stream: No such file or directory in /srv/www/web2/web/templates/bonq_nature/index.php on line 79

    Warning: main() [function.include]: Failed opening 'mainbody.php' for inclusion (include_path='/usr/share/php') in /srv/www/web2/web/templates/bonq_nature/index.php on line 79


    Warning: main(pathway.php) [function.main]: failed to open stream: No such file or directory in /srv/www/web2/web/templates/bonq_nature/index.php on line 29

    Warning: main() [function.include]: Failed opening 'pathway.php' for inclusion (include_path='/usr/share/php') in /srv/www/web2/web/templates/bonq_nature/index.php on line 29

    and this the error log after i rebooted the server

    [Sun Mar 11 23:50:22 2007] [notice] Graceful restart requested, doing restart
    PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib64/php/extensions/swf.so' - /usr/lib64/php/extensions/swf.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [Sun Mar 11 23:50:22 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sun Mar 11 23:50:22 2007] [warn] long lost child came home! (pid 10809)
    [Sun Mar 11 23:56:32 2007] [notice] caught SIGTERM, shutting down
    [Mon Mar 12 00:01:17 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib64/php/extensions/swf.so' - /usr/lib64/php/extensions/swf.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [Mon Mar 12 00:01:21 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations.

    I loaded up a new site in ispconfig with the same template and still getting the same errors.
    I have moved these sites to a windows server without ispconfig and a linux server with ispconfig and the site runs perfectly on both.

    shajazzi
     
  4. falko

    falko Super Moderator ISPConfig Developer

    It seems you enabled a module in your php.ini that doesn't exist. Please remove the appropritate extension= line in php.ini and restart Apache.
     
  5. shajazzi

    shajazzi Member

    Thanks for the response falko,
    I removed the offending extention and now the the error logs seem fine.

    [Mon Mar 12 14:15:51 2007] [notice] caught SIGTERM, shutting down
    [Mon Mar 12 14:15:52 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon Mar 12 14:15:52 2007] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations

    However i seem to still have the problem with the errors

    Warning: main(mainbody.php) [function.main]: failed to open stream: No such file or directory in /srv/www/web2/web/templates/bonq_nature/index.php on line 79

    Warning: main() [function.include]: Failed opening 'mainbody.php' for inclusion (include_path='/usr/share/php') in /srv/www/web2/web/templates/bonq_nature/index.php on line 79



    Warning: main(pathway.php) [function.main]: failed to open stream: No such file or directory in /srv/www/web2/web/templates/bonq_nature/index.php on line 29

    Warning: main() [function.include]: Failed opening 'pathway.php' for inclusion (include_path='/usr/share/php') in /srv/www/web2/web/templates/bonq_nature/index.php on line 29

    I have changed from PHP5 to PHP4 and visa versa a few times to see if this was causing the problem and have never enabled the extension on any Occation.
    I think that maybe Ispconfig must have written this to the php.ini file maybe if i have to do a reinstall i will first load a site in htdocs before installing ispconfig and also making a copy of php.ini to see if ispconfig writes this extension.
    Any more thoughts would be appreciated.

    shajazzi
     
  6. falko

    falko Super Moderator ISPConfig Developer

    It seems the include_path is wrong in your php.ini. What does it look like now?

    I think you should try
    Code:
    include_path = ".:/usr/share/php"
    instead.
     
  7. shajazzi

    shajazzi Member

    Thanks falko,
    I changed the line include_path = "/usr/share/php" to include_path = ".:/usr/share/php"
    restarted apache and all works fine now.
    Thanks again for your time.
    shajazzi
     

Share This Page