Joomla + suPHP + ispconfig + Etch causes too many processes!

Discussion in 'HOWTO-Related Questions' started by Insane1, Apr 18, 2008.

  1. Insane1

    Insane1 New Member

    Please help me. I started a server with ispconfig on debian etch. I secured the server with suphp. All done with the manuals here. But now, i got a big error. I moved my last page to the server and now, THIS site doesnt work. All the other Sites work, a smaller Joomla Site, too. But this Joomla Page doesn't.

    I checked out the memory and i saw, the webuser of the page causes 30-40 php5-cgi processes with hundrets of MBs Memory Usage. The Page timed out with a 500 error.

    i checked all the permissions but the error.log still gives me just one error:

    [Fri Apr 18 08:41:30 2008] [error] [client x.x.x.x] Premature end of script headers: index.php

    But all the permissions are correct! And the Page runs out of memory.

    Can you help me how to find the reason? is there a logfile i didnt find? How can i locate the script, which causes the error? :(
     
  2. falko

    falko Super Moderator

    What's the value of memory_limit from your php.ini?
    What's the output of
    Code:
    top
    ?
     
  3. Insane1

    Insane1 New Member

    memory_limit = 64M

    And top shows

    Code:
    12434 root      18   0  163m  17m 9.8m S  0.0  4.5   0:00.36 apache2
    15532 web16_go  16   0  114m  22m 8940 S  0.0  5.9   0:00.12 php5-cgi
     1446 mysql     15   0  153m  32m 4104 S 99.9  8.5  98:47.29 mysqld
    15219 www-data  15   0  164m  10m 3152 S  0.0  2.7   0:00.01 apache2
     2179 admispco  15   0 33516 5332 3148 S  0.0  1.4   0:05.79 ispconfig_httpd
    15221 www-data  15   0  164m  10m 3144 S  0.0  2.7   0:00.00 apache2
    15298 www-data  15   0  164m  10m 3140 S  0.0  2.7   0:00.00 apache2
    24795 admispco  15   0 33520 5300 3116 S  0.0  1.3   0:05.33 ispconfig_httpd
    15215 www-data  15   0  164m  10m 3076 S  0.0  2.7   0:00.01 apache2
    15222 www-data  15   0  164m  10m 3072 S  0.0  2.7   0:00.00 apache2
    15216 www-data  15   0  164m  10m 3064 S  0.0  2.7   0:00.00 apache2
    15220 www-data  15   0  164m  10m 3064 S  0.0  2.7   0:00.00 apache2
    15223 www-data  15   0  164m  10m 3064 S  0.0  2.7   0:00.00 apache2
    15290 www-data  15   0  164m  10m 3064 S  0.0  2.7   0:00.00 apache2
    15218 www-data  15   0  164m  10m 3060 S  0.0  2.7   0:00.00 apache2
    15217 www-data  15   0  164m  10m 3056 S  0.0  2.7   0:00.00 apache2
    15224 www-data  15   0  164m  10m 3052 S  0.0  2.7   0:00.00 apache2
    15466 www-data  15   0  164m  10m 3052 S  0.0  2.7   0:00.00 apache2
     9875 root      16   0 36788 2692 2120 S  0.0  0.7   0:00.00 sshd
     1534 postgrey  15   0 34444 5808 2108 S  0.0  1.5   0:02.87 postgrey
    web16_go is the web with the problem. All the other webs run perfect!

    (Lüneburg germany? Da könnten wir ja auch deutsch sprechen ;))
     
  4. falko

    falko Super Moderator

    Have you tried to increase the memory_limit, e.g. to 128M?

    I'm interested in the beginning of the top output. Can you post it again, maybe also the output of
    Code:
    cat /proc/meminfo
    ?

    Yes, but then nobody else can understand us. ;)
     
  5. SamTzu

    SamTzu HowtoForge Supporter

    What Joomla version is the website using?
    What extensions (components, modules, plugins, etc) is the website using?
    What version?

    I hear tell that a lot of spam is sent these days using old "buggy" php code.
    Joomla 1.0.x has had many security flaws.

    Upgrading to 1.5 may help.
     

Share This Page