Jobqueue backed up

Discussion in 'General' started by ra3don, Apr 3, 2009.

  1. ra3don

    ra3don New Member

    Hey everyone, and thanks for taking the time to read this.
    I am currently having a problem where I can't perform any action under ISPConfig. It just adds it to the jobqueue and they just keep stacking up. I have tracked down to this error:
    Code:
    maildirmake: /var/vmail/beastlytech.com/admin: Permission denied
    chown: cannot access `/var/vmail/beastlytech.com/admin': No such file or directory
    After I saw this, I set all of the permissions in the vmail recursively to the user vmail and the group vmail. However the jobqueue doesn't seem to be clearing...
     
  2. till

    till Super Moderator

    You have to clear / delete the last error in the jobqueue that holds the server from continuing in the jobqueue view of the monitor.
     
  3. ra3don

    ra3don New Member

    Ok, thanks for your reply. However, i did not see a way to do this. Do i do this through the ISPConfig webpage? I'm running ISPConfig 3.0.1.1
     
  4. till

    till Super Moderator

    The jobqueue is in the monitor module. You just have to click on the delete icon of the error message in the jobqueue.
     
  5. ra3don

    ra3don New Member

    I must be doing something wrong. There isn't an error in the jobqueue but nothing has moved for the past 3 days. I've attatched a screenshot of what i'm seeing. I found out there was an error in the cron.log.

    [​IMG]
     
  6. ra3don

    ra3don New Member

    I finally gave in and just ended up uninstalling ISPConfig and reinstalled it. Everything seems to be working just fine now. Thanks for the help.
     
  7. snorkels

    snorkels New Member

    jobqueue not moving

    Same problem here running ispconfig 3.0.1.1. Jobqueue just stopped working, after a month of succesfull uptime.
    Looking in this thread with similar problem:
    http://www.howtoforge.com/forums/showthread.php?t=33445&referrerid=60006

    Could be mysql perrmisions problem ? How to fix it ?

    Also reinstallation is not possible due to allready deployed websites.
     
  8. till

    till Super Moderator

    Take a look at page 4 of the jobqueue, there must be an error at the end of the last page. Fix the reson for the error and then delete the error in the list.
     
  9. snorkels

    snorkels New Member

    Jobqueue not responding

    Thanks for the very quick reply ! :)
    There is no error message.
    [​IMG]
     
  10. snorkels

    snorkels New Member

    Commands no executing

    I`ve gone threw the logs, and they show no errors.
    Where could be the problem that command are not executing and staying in queue ?
     
  11. till

    till Super Moderator

    Please enable debugging in /usr/local/ispconfig/server/lib/config.inc.php and then run the following command as root user:

    /usr/local/ispconfig/server/server.sh

    and post the output.
     
  12. snorkels

    snorkels New Member

    Resolved

    Hello,
    Thanks for the quick reply,
    After executing as root /usr/local/ispconfig/server/server.sh
    as mac users sometimes says - it just works :) !

    root@ronis:~# /usr/local/ispconfig/server/server.sh
    18.05.2009-10:47 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    18.05.2009-10:47 - DEBUG - Found 7 changes, starting update process.
    ...
     
  13. beryl

    beryl New Member

    Hello,

    I get the
    DEBUG - There is already a lockfile set. Waiting another 10 seconds...

    Error, for several hour.

    How do i find the correct lockfile to delete?
     
  14. Croydon

    Croydon HowtoForge Supporter

    /usr/local/ispconfig/server/temp/.ispconfig_lock
     
  15. beryl

    beryl New Member

    Now it works :)

    But i get

    msg 90/90 (822 bytes), delivery error (command sendmail 3575 error (127, exec of command sendmail failed (refuse to invoke external commands as root or GID 0 by default)))

    When i run /usr/local/bin/run-getmail.sh
     
  16. Croydon

    Croydon HowtoForge Supporter

    You may not run this command as root.
    ISPConfig runs it under the user "getmail".
     
  17. beryl

    beryl New Member

    Had a feeling it was so, thanks for verifying :)
     
  18. beryl

    beryl New Member

    Hello,

    After running apt-get upgrade, and running upgrades for apache, kernel etc. I get the Error: configuration file /etc/getmail/*.conf does not exist

    Of course, getmail command works.

    And there are two fetchmail commands inside ispconfig.

    I also tried removing them and recreating them, making sure they where processed.

    still... Error: configuration file /etc/getmail/*.conf does not exist

    And true, there are no .config files in /etc/getmail/*.conf

    What do do?!!
     
  19. Nicke

    Nicke New Member


    Thats normal.
    You don't have to do anything.
    We all get that message when we don't have any fetchmail configured.

    Edit:
    I see... you DO use fetchmail? Then.. i dont know. ;-)
     
  20. beryl

    beryl New Member

    True, i do have fetchmail... :-(

    And Till is offline... aaah! This is extremely annoying.
     

Share This Page