JobQueue backed up and nothing is being created

Discussion in 'ISPConfig 3 Priority Support' started by babydunk, Aug 8, 2016.

  1. babydunk

    babydunk Member HowtoForge Supporter

    Hello :D
    i was in the middle of using APS installer. setting up a wordpress site. nothing was created and that why im here lol

    i am on debian 8.4 and was on Ispconfig version 3.0.5.4p9 but i upgraded the 3.1rc1 which did not help but then i noticed the jobqueue full to the neck.

    this is what i get in debug mode.
    Test script
     
  2. babydunk

    babydunk Member HowtoForge Supporter

     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the lock file and check if the queue gets processed again:

    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock
     
  4. babydunk

    babydunk Member HowtoForge Supporter

    i already done this at 3 this morning but it didn't change anything. i will give it another go here
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the lock file and then run /usr/local/ispconfig/server/server.sh directly to see why the script dies without being able to remove the lock file.
     
  6. babydunk

    babydunk Member HowtoForge Supporter

    No the jobqueue hasn't start again

    heres the first of the 11 pages in que - page 11
     
  7. babydunk

    babydunk Member HowtoForge Supporter

     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Install the php curl extension.

    apt-get install php5-curl
     
  9. babydunk

    babydunk Member HowtoForge Supporter

    done that also at 3 this morning lol. would it be best to remove it and install it again?

     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    post the output of:

    php -v
     
  11. babydunk

    babydunk Member HowtoForge Supporter

    how did i get version 7 in my box. don't remember installing that

     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    If I remember correctly, there was an issue with dotdeb, they upgraded php to 7.0 without asking.

    First, check which is your php 5 binary, I guess its most likely: /usr/bin/php5

    If thats the case, run:

    update-alternatives --set php /usr/bin/php5

    to make php 5 the default php again.
     
  13. babydunk

    babydunk Member HowtoForge Supporter

    Thank you again Till i couldn't have fix it without you :D

    setting php5 to default sorted the problem

    thanks again ;)
     

Share This Page