Jobque stopped - i have a "fatal error"

Discussion in 'Installation/Configuration' started by janvl, Dec 7, 2021.

  1. janvl

    janvl Member

    i am installing a server with ispconfig on Ubuntu 20.04 with several PHP-versions.
    I solved one of my mistakes already but now the jobque stops with 4 actions that "hang".
    I do not see any errors within ISPconfig - Systemlog.

    I have editted the crontab - disabled the line that starts and then ran it manually.
    In the output I have a fatal error that i do not know what it means:

    PHP Fatal error: Uncaught TypeError: count(): Argument #1 ($value) must be of type Countable|array, bool given in /usr/local/ispconfig/server/lib/classes/ : eval() 'd code:77

    Does anyone have an idea where i should look or what can i do to simply empty the "jobque" and first double check all settings.
    So far i did not trust myself deleting the entries in the table sys_datalog.

    i found this:
    but that is to deep in the sourcecode for my level of php-knowledge - i do not trust myself changing that
    Last edited: Dec 7, 2021
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Like @Taleman mentioned, you are using the wrong PHP version. See chapter "ISPConfig is not writing changes to disk" on the page that Taleman posted.
  4. janvl

    janvl Member

    thanks, i ran the script.
    it is clear now, the php cli version is 8.0 which should have been 7.4.
    I will see that i change that.

    Building up a new server is not an everyday job, i run a server with ispconfig for over a year now and it runs very stable.
    This will be the next one.

    Any hint is welcome.
    edit - no need already changed it and ISPConfig is running smoothly again!

    Last edited: Dec 7, 2021

Share This Page