Job Queue Not Processing

Discussion in 'Installation/Configuration' started by JANorman, Apr 19, 2011.

  1. JANorman

    JANorman New Member

    Hiya,

    I am running a standard install of ISPConfig 3 on my Debian (Lenny) based server which only controls the one server.

    The problem that I am having is that for about 2 weeks now, my cron job queue has not been processing and hence, noting is being done (e.g. adding new sites, updating settings etc. )

    I have been looking up similar issues on the net, and have run the command "/usr/local/ispconfig/server/server.sh", but it has not shifted the queue.

    When that command is run, I repeatedly the message:
    sh: /ps: No such file or directory

    I'm really struggling on this one and would really appreciate someones help.

    Cheers,
    James
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Has the syste worked before? If yes, what have you done or reconfigured at the time it stopped working?
     
  3. JANorman

    JANorman New Member

    Hi,

    Yea, its worked previously before.

    I dont recall changing anything.

    Do you think it would help if I cleared the records from sys_datalog ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Dont do that, clearing the records in that table will cause the system to stop.

    Which ISPConfig version do you use?
     
  5. JANorman

    JANorman New Member

    Im using 3.0.3.1 .

    Just having a look in the sys_datalog, there are quite a few more in there that are "pending" than what show on the site, could the first one be holding them up?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok. The status field is not in use, so it is always pending. You can not see in the sys_datalog which records have to be processed.

    Please update your server to the current ispconfig version (3.0.3.3). You can do this by running the command:

    ispconfig_update.sh

    on the shell.

    If this wont fix the problem, enable debugging in ispconfig under system > server config. Then run the command:

    /usr/local/ispconfig/server/server.sh

    as root user while you are logged in on the shell as root. Dont use sudo to execute it.
     
  7. JANorman

    JANorman New Member

    I've just tried to update it, and I'm not 100% sure if it has gone through or not.

    On http://www.ispconfig.org/releases/ispconfig-3-0-3-released/ , i followed the manual upgrade technique, so i executed the following:

    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php


    It took me through the setup, but when I still go onto the control panel it displays 3.0.3.1 !

    I still get the sh: /ps error message from above.

    Cheers
     
  8. JANorman

    JANorman New Member

    Ive just run the ispconfig_update.sh command, and it says that i'm now on 3.0.3.3 .

    Still getting:


    /# /usr/local/ispconfig/server/server.sh
    sh: /ps: No such file or directory
     
    Last edited: Apr 20, 2011
  9. JANorman

    JANorman New Member

    Hi Till,

    Sorry, i misread your reply. So I changed the reporting level to Debug, and then re-run the script and the output was now:

    Code:
    custard:/var/log/ispconfig# /usr/local/ispconfig/server/server.sh 
    sh: /ps: No such file or directory
    
    Warning: fopen(): SAFE MODE Restriction in effect.  The script whose uid is 5003 is not allowed to access /var/log/ispconfig/ispconfig.log owned by uid 0 in /usr/local/ispconfig/server/lib/app.inc.php on line 115
    
    Warning: fopen(/var/log/ispconfig/ispconfig.log): failed to open stream: Success in /usr/local/ispconfig/server/lib/app.inc.php on line 115
    Unable to open logfile.
    
    ---
    The safe mode restriction is an odd one, because in my master php.ini file, it is turned off, aswell as in all my other files.

    I also removed the ispconfig.log file and replaced it with a clean one, and changed the permission to 777, but this did not fix it.

    Cheers
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Safemode is not compatible with php shell scripts and has to be turned off. Its deprecated anyway. Please check again all php.ini files and the includes in the php conf.d directories. You must have turned safemode on somewhere.

    Plaese do not change the permissions of that file. It is not related to your problem and altering that file permissions might cause problems.
     
  11. JANorman

    JANorman New Member

    Hi Till,

    Thanks for the advice. I thought that I had turned it off but one of the files slipped through.

    After I turned it off, I got the errors listed on this page:
    http://www.howtoforge.com/forums/showthread.php?t=42597&page=2

    I followed them and managed to resolve the issue.

    Thanks Till, for all your support.

    Cheers

    James
     

Share This Page