Job Queue not processing in ISPConfig 3.0.4

Discussion in 'Installation/Configuration' started by AppSol, Jul 5, 2012.

  1. AppSol

    AppSol New Member

    Hello,
    I've been through the forums and can't see an answer for this.
    My Job queue in Monitor >> System State >> Show Jobqueue does not go down. This means changes to the sites are not being applied.

    If I try to run /usr/local/ispconfig/server/server.sh
    as root I get a response: 'Could not startup'

    I tried to enable debug mode in ISPConfig through the control panel, but this did not apply so I updated the config file /usr/local/ispconfig/server/lib/config.inc.local.php with:
    Code:
    $conf['log_priority'] = 0;
    Yet the file /var/log/ispconfig/ispconfig.log is not updated when I try to run the script.

    The server is Ubuntu 10.04 and ISPConfig version is 3.0.4

    Thanks, Stuart
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please undo that, these settings get ignored. The only place to enable or disable logging i the ispconfig interface as described in the faq.

    Then run the command:

    /usr/local/ispconfig/server/server.sh

    as root user and post the exact line(s) that you get on the shell. Have you modified nayging in the php cli php.ini file? If yes, then undo these modifications. especially dsabling functions will cause the process to fail.
     
  3. AppSol

    AppSol New Member

    Hello Till,

    I tried that but it didn't apply any changes even when I ran /usr/local/ispconfig/server/server.sh as root

    I am running as as root by sudo su, but I also tried it as true root by sudo bash

    All I get back is 'Could not startup'

    I was getting some warnings about the wrong comment usage in some php ini files but I fixed those ('# comments are depreciated')

    I did alter one thing in php cli php.ini and that was to add a 128mb limit to max memory but I have set that back to 0

    I checked for .lock files to see if there were current running occurrences of the script but nothing.

    Sorry it's a bit vague, let me know what I can do to get more meaningful logs out.

    Thanks

    Stuart
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is this a physical server or a virtual machine? How much RAM have you got?
     
  5. AppSol

    AppSol New Member

    Hello till,

    it's a VPS on VPS.net, I've got 2256Mb of Ram.

    The reason I am trying to change the configuration on the server is that it keeps running out of Ram. This I think is due to a mixture of PHP-FCGI and APC cache, as it seems to spawn an unnecessarily large number of php-cgi processes which, as far as I can tell, is causing issues with APC cache, so the memory gets eaten up quickly.

    Don't know if any of that helps, but let me know if there is anything I can run to give you a clue.

    thanks

    Stuart
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Not sure if this is a typo or not - 2256MB or 256MB? 256MB would be rather low - you should at least have 512MB, better 1GB.
     
  7. AppSol

    AppSol New Member

    Hello Falko,

    no 2256Mb, it's got 6 VPS nodes, which VPS state:
    so 6 * 376 = 2256Mb

    Let me know if you can think of anything else I can look at to resolve this as I am having to kill large numbers of php-cgi processes every day to keep the server up and running, so I need to take control of the server. I can go and edit the sites-available, but I don't want to over write anything that ISPConfig will then write over.

    Thanks

    Stuart
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig requires at least 512, better 1GB per node. Otherwise some of the services will fail because there is not enough RAM to start all of them.
     
  9. AppSol

    AppSol New Member

    I don't think you understand me, the idea of nodes is just a way that VPS.net allow me to add or take away resources from my servers in chunks. The VPS server as a whole has 2256Mb available so should be able to run ISPConfig easily.

    Thanks

    Stuart
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. A node is normally a term for a independant processing unit with its own operating system instance.

    Have you installed any additional PHP modules or did you change anything in the php.ini file? A common mistake is to set the php memory size too low e.g. because you missed to add the unit directly after the size e.g. a memory size of 128 is 128 Bytes and not Megabytes. while 128M is 128 Megabytes.
     
  11. AppSol

    AppSol New Member

    Hello, sorry I've been snowed under with work for a while, but I'm still no further forward with this.

    As a possible solution I decided to try and update ISPConfig from the command line, but all I get is the response 'Could not startup.'

    The web site on this server is using PHP FCGI, which is I think behind some out of memory issues it is getting. I need to change this to mod_php as I'm hoping this will resolve the issue. The client is not happy at the server performance, and is making 'move hosts' noises, so I would appreciate an idea on where to look next.

    I have bought the ISPConfig manual but cannot find an answer in there. I'm at a bit of a dead end, so any advice would be great.

    Thanks

    Stuart
     
  12. falko

    falko Super Moderator ISPConfig Developer

Share This Page