Jessie -> Stretch system

Discussion in 'ISPConfig 3 Priority Support' started by Norman, Nov 22, 2019.

  1. Norman

    Norman Member HowtoForge Supporter

    Hi,

    I've got a system that was originally on jessie.
    Attempting to run PHP7 FPM processes render 503 errors .
    Errorlog for the sites show:
    [Fri Nov 22 01:20:50.001978 2019] [proxy:error] [pid 12486] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/php5-fpm/web5.sock (*) failed
    [Fri Nov 22 01:20:50.002054 2019] [proxy_fcgi:error] [pid 12486] [client 89.160.78.244:51585] AH01079: failed to make connection to backend: httpd-UDS
    [Fri Nov 22 01:20:51.092331 2019] [proxy:error] [pid 12449] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/php5-fpm/web5.sock (*) failed
    [Fri Nov 22 01:20:51.092395 2019] [proxy_fcgi:error] [pid 12449] [client 89.160.78.244:51587] AH01079: failed to make connection to backend: httpd-UDS

    If I uncheck the Use Socket for PHP-fpm the PHP exeuction works for FPM.
    Any idea what might be wrong?

    I went through a perfect setup guide for stretch to check so Im not missing any dependency or a2mod .
    [email protected]:/var/lib/php5-fpm# ls -la
    total 8
    drwx------ 2 root root 4096 Nov 22 01:15 .
    drwxr-xr-x 57 root root 4096 Nov 22 01:07 ..
    srw-rw---- 1 web5 www-data 0 Nov 22 01:15 web5.sock


    Tried creating a fresh site on this server, same thing.
    Not sure what this server might be missing or have issues with. Any idea?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you change the paths to match the enw PHP version under System > server config in ISPConfig? And did you run an ispconfig update with reconfigures services = yes after you upgraded the system?
     
  3. Norman

    Norman Member HowtoForge Supporter

    I've run php -q update.php and let it reconfigure services.
    System ->Server config -> Web -> PHP settings are untouched.
    /etc/php5/apache2/php.ini
    /etc/php5/cgi/php.ini
    php5-fpm
    /etc/php5/fpm/php.ini
    /etc/php5/fpm/pool.d
    9010
    /var/lib/php5-fpm
    [website_path]/web:[website_path]/private:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom

    Should these be changed?
    I'm using additional settings for PHP according to https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/ to add support for PHP 7.2 / 7.3 .
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yesm these should be changed to match the paths for the currently used system PHP.
     
  5. Norman

    Norman Member HowtoForge Supporter

    Alright, I found an old thread where you mentioned that it didnt matter if it used /var/lib/php5-fpm still.
    But can you assist me in what paths are accurate?

    I've got PHP 7.0 , 7.2 and 7.3 installed now using the other guide.
    So which values for the system global should I set?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    /etc/php/7.0/apache2/php.ini
    /etc/php/7.0/cgi/php.ini
    php7.0-fpm
    /etc/php/7.0/fpm/php.ini
    /etc/php/7.0/fpm/pool.d
    9010
    /var/lib/php7.0-fpm
    [website_path]/web:[website_path]/private:[website_path]/tmp:/var/www/[website_domain]/web:/srv/www/[website_domain]/web:/usr/share/php/7.0:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom
     

Share This Page