Java applets in Iceweasel on Debian amd64

Discussion in 'Desktop Operation' started by Hans, Jan 27, 2009.

  1. Hans

    Hans Moderator ISPConfig Developer

    On my new laptop, i am running Debian Lenny/Sid AMD64 and i'am very pleased with it. It is fast, stable and it provides everything i need. I switched completely to Linux (now also on the desktop), and i do not miss Windows one single day!

    Everything is working great, except one thing:
    I can't run Java applets in Iceweasel. I've tried the Debian package icedtea-gcjwebplugin but it does not always work.

    Can someone give me some information, what i have to do to run Java applets succesfully in Iceweasel on Debian AMD64?

    Thanks in advance!
    Last edited: Jan 27, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to install the sun-java6* packages?
  3. Hans

    Hans Moderator ISPConfig Developer

    Hi Falko,
    The screendump shows what is available and what i've installed. Do i miss something?

    Attached Files:

  4. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. When you search for mozilla in Synaptic, are there any Java plugins?
  5. Hans

    Hans Moderator ISPConfig Developer

    Java on 64bit browser Iceweasel

    I did not find any java related package by using the search string "Mozilla". The problem is that there is no java6-plugin package available for amd64.
    I decided to install icedtea-gcjwebplugin package again. Now it's working quiet good! :) First. not, probably i did not restart Iceweasel after the first installation.

    About IcedTea:
    IcedTea provides a working browser plugin for 64-bit browsers under 64-bit Linux. This makes it suitable to enable support for Java applets in 64-bit Firefox, so also Iceweasel.

    For more information, click here.
  6. marpada

    marpada New Member

    Last edited: May 13, 2011

Share This Page