Jailkit doesn't seem to be working, how to test?

Discussion in 'Installation/Configuration' started by newmember, Jan 3, 2011.

  1. newmember

    newmember New Member

    Jailkit doesn't seem to be working, how to test? [SOLVED]

    I installed jailkit before ispconfig3.
    I selected jailkit with new shell user.

    But the user can travel through directories, how do I test if jailkit is working or setup correctly?
    Ubuntu Server ver10.10

    Thanks

    Linux webserver.workdesk.ca 2.6.35-24-server #42-Ubuntu SMP Thu Dec 2 03:58:11 U TC 2010 x86_64 GNU/Linux
    Ubuntu 10.10

    Welcome to the Ubuntu Server!
    * Documentation: http://www.ubuntu.com/server/doc
    Last login: Sun Jan 2 20:02:40 2011 from 192.168.100.109
    web8@webserver:~$
    web8@webserver:~$
    web8@webserver:~$
    web8@webserver:~$ ls
    bin cgi-bin dev etc home lib lib64 log ssl tmp usr var web
    web8@webserver:~$ cd ..
    web8@webserver:/var/www/clients/client0$ cd ..
    web8@webserver:/var/www/clients$ cd ..
    web8@webserver:/var/www$ cd ..
    web8@webserver:/var$ cd ..
    web8@webserver:/$ ls
    bin etc lib mnt sbin sys vmlinuz
    boot home lib64 opt selinux tmp vmlinuz.old
    build initrd.img lost+found proc srv usr webmin-setup.out
    dev initrd.img.old media root ssl var
    web8@webserver:/$
     
    Last edited: Jan 4, 2011
  2. pavljiks

    pavljiks New Member

  3. till

    till Super Moderator

    1) Which Jailkit version do you have installed?
    2) Have you selected jailkit as you created the SSH user?
    3) Post the lines for the web8 user and the shell user that you used to login from /etc/passwd
     
  4. newmember

    newmember New Member

    1. ver2.13
    2. yes, I selected jailkit when adding the shell user web8
    3.
    I just tried adding a new shell account and I can see that jailkit was added.
    I just tested the SFTP for user web8.domain.ca and I am kept in the chroot folder.

    Not sure what I did differnetly, but after my initial port I did try to install jailkit again.
    I will try a complete reinstall following the "perfect-server-ubuntu-10.10-maverick-meerkat-ispconfig-3" and see if I do better.

    Looking good.
     

Share This Page