jailkit - Activate jailkit user can't login

Discussion in 'General' started by DaWy, Feb 1, 2013.

  1. DaWy

    DaWy New Member HowtoForge Supporter

    Hi guys! I've just installed ISPConfig with one OVH Dedicated Servers. (self install)

    I've fallen in love with ISPConfig, its just amazing... but there's one thing I cant make it work (Sorry for my horrible english)

    When I create a new ssh user for one website folder, I can connect with it without the jailkit enabled (so chroot option is "none"), but if I enable the option to "jailkit" the user can't login (it logins but insta kick him).

    This is the log from the /var/log/auth.log when user's connect:


    Code:
    Feb  1 14:22:28 ks3266342 sshd[6088]: Accepted password for test from 88.1.35.95 port 57056 ssh2
    Feb  1 14:22:28 ks3266342 sshd[6088]: pam_unix(sshd:session): session opened for user test by (uid=0)
    Feb  1 14:22:29 ks3266342 jk_chrootsh[6095]: now entering jail /var/www/clients/client1/web2 for user test (5006) with arguments
    Feb  1 14:22:29 ks3266342 jk_chrootsh[6095]: abort, failed to find user 5006 in /var/www/clients/client1/web2/etc/passwd
    Feb  1 14:22:30 ks3266342 sshd[6088]: pam_unix(sshd:session): session closed for user test
    The file that it says that does not exists (/var/www/clients/client1/web2/etc/passwd)ofc it exists. Here it comes:

    Code:
    root:x:0:0:root:/root:/bin/bash
    test:x:5006:5006:::/bin/bash
    
    So whats the problem? I've updated jailkit to the last version (2.5) still not working.

    Im sure jailkit is working, cuz if I remove the jailkit option in the chroot option on user edit, the user can login, but then he can browser all the path's... so thats not viable ofc.

    My brain is starting to became black mat... :(

    Anyone can help with this? thnx in advance!!!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ispconfig version do you use?
     
  3. DaWy

    DaWy New Member HowtoForge Supporter

    oops! I forget to write that... :D

    Im using last stable ver. ISPConfig 3.0.4.6

    Thanks for the answer!

    EDIT: Thanks for the very fast answer!!!!!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok.Jailkit should work there. What makes me wonder is that the path to the home directory is missing in the line:

    test:x:5006:5006:::/bin/bash

    Please check if "Jailkit chroot home" under System > server config > jailkit is set to:

    /home/[username]
     
  5. DaWy

    DaWy New Member HowtoForge Supporter

    Yes it is. I've just checked the server conf, and the jalkit chroot folder is set to: /home/[username]

    Maybe its cuz I've updated manually the jailkit to 2.5? Dunno...
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. Please post the line from /etc/passwd for this username.
     
  7. DaWy

    DaWy New Member HowtoForge Supporter

    This is the line where user "test" appears at /etc/passwd:

    Code:
    test:x:5006:5006::/var/www/clients/client1/web2/./home/test:/usr/sbin/jk_chrootsh
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok as well. I just cjecjed a working jailkit user on ym server and I was wrong with my post above that the path is missing in the "test:x:5006:5006:::/bin/bash" line, I dont have that path in my working paswd file as well.

    May you please try to delete the ssh user in ispconfig, then create it again as jailed user to see if this fixes it.
     
  9. DaWy

    DaWy New Member HowtoForge Supporter

    I deleted the test user and created one more. Its happening the same... :(
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe it is realy a issue with jailkit 2.15 then. I havent tested this jailkit release with ispconfig yet.
     
  11. bulke

    bulke New Member

  12. DaWy

    DaWy New Member HowtoForge Supporter

    So still no solve for this problem, and now I have to solve it (couse i'm starting having clients that want SSH access...).

    Any tip for this?
     
  13. Jack78

    Jack78 New Member

    Hi,

    First, thanks for IspConfig which is a beautiful tool.

    I would like to tell you that I've exactly the same problem :
    Following this standard documentation : http://www.howtoforge.com/perfect-se...ot-ispconfig-3

    Configuration :
    - ubuntu 12.04
    - jailkit-2.16
    - ISPConfig-3.0.5.3

    If somebody has an idea ...

    Brgds
     
  14. DaWy

    DaWy New Member HowtoForge Supporter

    I'm still stuck with the jailkit. Im gonna migrate my server, so I will test it again. Don't know why not working on a ISPConfig pre-installed distro.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    You should ask this your isp. On the isconfig servers that we install for our clients, jailkit works out of the box.

    Jack68 installed a different jailkit version as described in the tutorial, it might be that jailkit 2.16 does not work. I've tested just until 2.15 and the 2.15 version works out of the box on Debian and Ubuntu Linux.
     
  16. DaWy

    DaWy New Member HowtoForge Supporter

    I will try to install it from the Debian base, following the main tutorial... Btw, i changed to version 2.15 and it also didn't work.
     
  17. Jack78

    Jack78 New Member

    Confirm not working and not due to ISP

    Hi Till,

    I confirm you it's not a question relative to ISP.
    I've make it at home on a fresh server install with absolutely nothing else than standard ubuntu server.

    Nota : it seems that several other people have this problem (no solution for the moment on the forum).

    Brgds
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Which jailkit version did you install and which errosr do you get in the syslog?
     
  19. Jack78

    Jack78 New Member

    Syslog

    Hi Till,

    I use jailkit-2.16

    Syslog informations are only :
    Tonight I will began a fresh reinstallation with jailkit-2.15 and will tell you.

    Brgds
     
  20. tonymontana5000

    tonymontana5000 New Member

    Only upgrading JK didnt help me.

    But this post did:
    http://www.howtoforge.de/forum/34884-post7.html

    JK login Works after adjusting jk_init.ini

    Edit:
    Now i'm on JK 2.17 with edited jk_init.ini and it works fine... Had to recreate jails though because the libraries werent copied..
     
    Last edited: Jan 21, 2014

Share This Page