itop and upload_max_size

Discussion in 'General' started by unsichtbare, Jul 9, 2014.

  1. unsichtbare

    unsichtbare Member

    Hi all,

    I searched and found similar problems but no solution for me!

    ISPconfig 3.0.5.4 running on Ubuntu Server 14.04 (2 cores, 4GB)

    I installed a CMS known as iTop (ticketing and change management) with no problems. Actually, the version of PHP that the initial check validated to was CGI, so I used that.

    Site seems to work perfectly, but I can't upload even tiny PDF files without being told "Error: The uploaded file is too big. (Max allowed size is 2G)." These are small PDF's, a few MB at most.

    Anyway I did the only sensible thing, I increased the post_max and upload_max to ridiculous sizes and I still get the same message! I even tried editing the value in /etc/php5/cgi/php.ini and restarting apache2 - to no avail.

    I have since reset the /etc/php5/cgi/php.ini settings to default and re-applied the following settings to the Custom php.ini settings for the site:
    Code:
    memory_limit = 1G
    file_uploads=On
    post_max_size=4G
    upload_max_filesize=2G
    
    Furthermore, the setting changes have all been validated by phpinfo!

    Any help appreciated.

    -J
     
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Please check the link, it is for drupal but it might help with iTop too.
     
  3. unsichtbare

    unsichtbare Member

    Thanks for the suggestion. I reviewed the post and the relevant section seemed to imply to simply comment out both ;upload_max_filesize and ;post_max_size.

    I had not tried this before, so I did, but no success. Commenting these values out of php.ini left default values of 8M/16M.

    Thanks again.

    -J
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    create a php file with:

    <?php
    phpinfo();
    ?>

    inside, upload it to your site and open it n your browser. there you will see in the output which php.ini file is used in this case.
     
  5. unsichtbare

    unsichtbare Member

    The php.ini is the same file that I modified. (/etc/php5/cgi/php.ini)

    That being said, I would rather set PHP directives by site, rather than by type of PHP - but am willing to try anything.

    -Thanks

    -J

    -John
     

Share This Page