"It works", but it doesn't actually :-(

Discussion in 'Installation/Configuration' started by Puppetmaster, Feb 8, 2009.

  1. Puppetmaster

    Puppetmaster New Member

    Hello.
    I've been following the guide: "The Perfect Server - Ubuntu Intrepid Ibex (Ubuntu 8.10)", after that I have been using the installation guide to ISPConfig...
    The ISP Controlpanel is working...
    I've created a test site: www.lutzen.dk, and have set up DNS (go ahead, test it). So if you try to look up the IP for www.lutzen.dk you get the correct IP: 82.143.204.139.
    But, my server just returns "It works" from "/var/www/index.html".
    It's like the virtual hosts is not working. That it doesnt get the Virtual Host config included or something...
    I've looked in some other threads and now I placed my server outside DMZ. But it did not change anything...

    What info should I post to help solve my problem?

    This is the first time I play with these things. So I really doesn't have a clue what I did wrong...

    I hope one of you can point me in the right direction
     
  2. Allen15

    Allen15 New Member

    Hello. I have felt your pains recently too.

    If you can get to the "It Works!" page when browsing, and not a "Shared IP" warning page, then Apache is working with the default installation page, but ISPConfig is not.

    DO NOT MAKE CHANGES TO YOUR ROUTER!

    Getting to the default Apache page says that packets and requests are going to the correct places, so don't go fixing what is not broken, it will only frustrate you more. Try:

    /etc/init.d/ispconfig_server start

    and see if you can start ISPConfig, although I suspect that there is a greater chance that you have a failed installation of ISPConfig, and may need to remove it and re-install it? Before you do a reinstallation, check your install logs for errors to see if there are more clues to point you toward your next success, like missing packages that may have crashed the install and the like.

    Good luck, hang in there, and keep asking questions -- I've found that together, we CAN get there.

    Allen
     
  3. Puppetmaster

    Puppetmaster New Member

    Still nothing

    I tried to start the ISPConfig with the:
    Code:
    root@server1:/etc/init.d/ispconfig_server start
    Then I got this response:

    Code:
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd (pid 4992) already running
    FreshClam is already running!
    ISPConfig system is now up and running!
    It looks like that was not the problem...
    What log files should I look in? And where are they placed? "/var/log/messages"?

    It might be a broken installation... It I just apt-get install all the packages that ISPConfig requires, then if they are already installed it will just do nothing, or if I is not installed, then it would install it...
    Then what packages should I check for?

    Re-installation, no problem:) I will do that when I figure out what I am missing.
     
  4. till

    till Super Moderator

    Most likely you entered the wrong IP address. make sure that you used the internal IP address were you forwarded port 80 to from your router for the website that you created in ispconfig.
     
  5. Puppetmaster

    Puppetmaster New Member

    I have altered the "It works" page, to ensure that it was my IP.
    If you look: http://82.143.204.139/ it is the correct IP.
    I have taken a screenshot of the setting in my router setup...
    My servers internal IP is 192.168.2.4...
     

    Attached Files:

  6. codydwilson

    codydwilson New Member

    Had the same problem as well. Had to do with DNS i belive, are you using godaddy for your domain? If so you have to * out the ip address in your vhosts ispconfig file, at least that's what worked for me.

    Here's the thread that helped me
     
    Last edited: Feb 9, 2009
  7. Puppetmaster

    Puppetmaster New Member

    No I am not using GoGaddy.
    I am using Gratisdns.dk.

    What info is needed? I checked in my apache2.conf, and I get the Vhosts_ispconfig included as far as I can see...

    I am new to this so I am fumbling in the dark :-(
     
  8. Puppetmaster

    Puppetmaster New Member

    I just tried to fill in some "wefdwfefwwfe" in the "vhosts/Vhosts_ispconfig.conf" and when I reloaded apache it died.
    So it is included...

    Then i tried playing around with the IPs.. and it solved the problem!! Thanks for the HELP!

    And now it works. Thanks for your help!!
     

Share This Page