Issues with www. and no www.

Discussion in 'Installation/Configuration' started by xstnc, Sep 15, 2011.

  1. xstnc

    xstnc New Member

    Hi,

    I'm having a kind of wierd problem with my newly installed ISPConfig 3 setup.
    I've got two DNS servers linked together, and bought the domain: honstreams.com just for testing purposes.

    When I go to www.honstreams.com it works fine, but if I drop the www. I get nowhere.

    If I run dig @localhost this is the output:

    Code:
    me@server:/$ dig @localhost honstreams.com
    
    ; <<>> DiG 9.7.0-P1 <<>> @localhost honstreams.com
    ; (2 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37079
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;honstreams.com.                        IN      A
    
    ;; ANSWER SECTION:
    honstreams.com.         86400   IN      A       178.21.129.124
    
    ;; AUTHORITY SECTION:
    honstreams.com.         86400   IN      NS      ns2.avestahosting.no.
    honstreams.com.         86400   IN      NS      ns1.avestahosting.no.
    
    ;; ADDITIONAL SECTION:
    ns1.avestahosting.no.   86400   IN      A       178.21.129.124
    ns2.avestahosting.no.   86400   IN      A       89.191.27.202
    
    ;; Query time: 10 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Sep 15 11:13:35 2011
    ;; MSG SIZE  rcvd: 132
    
    This looks OK doesn't it?

    So I just can't figure out why it doesn't work properly..

    Any thoughts?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    It's working for me. Sometimes it can take up to 72 hours until DNS changes propagate. I guess this was the problem here.
     
  3. xstnc

    xstnc New Member

    The changes were much older than 72 hours.
    I have no idea what I did to make things work - so any thoughts on what it COULD have been would be awesome!
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Maybe your browser cache?
     
  5. xstnc

    xstnc New Member

    It's a good thought, but it's not just on one computer - and not only one browser.

    And even tried cleared the cache!

    Oh well, seems to work now - even if I have no idea what I did..
     
: bind, dns, www

Share This Page