Issues with MyDNS and ISPConfig 3.0.0.8

Discussion in 'General' started by koltz, Feb 4, 2009.

  1. till

    till Super Moderator

    Change the lines:

    Code:
    NameVirtualHost *
    NameVirtualHost *:80
    <VirtualHost *>

    to:

    Code:
    NameVirtualHost *:80
    <VirtualHost *:80>
     
  2. koltz

    koltz New Member

    Doesn't do anything for helping the SSL to work (port 443).
     
  3. koltz

    koltz New Member

    Anyone? See a couple messages above for the actual SSL/443 issues. I am looking at all of the site configs for ISPConfig3 and do not see any thing setup for SSL. I do have it enabled it under the site that needs it, but no reference under default or the specific Vhost file for the NameVirtualHost.
     
  4. till

    till Super Moderator

    You have to create a ssl certificate on the ssl tab.
     
  5. koltz

    koltz New Member

    It had one created originally, didn't start. I tried copying the GoDaddy cert as also mentioned. I then clicked the thing to Create Certificate, created it's own and I tried to restart apache but wouldn't. Here is my Vhost files:

    8bitclassics.com.vhost
    Code:
    
    <VirtualHost 172.21.152.31:80>
          DocumentRoot /var/www/8bitclassics.com/web
    
        ServerName 8bitclassics.com
        ServerAlias www.8bitclassics.com
        ServerAdmin webmaster@8bitclassics.com
    
        ErrorLog /var/log/ispconfig/httpd/8bitclassics.com/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        <Directory /var/www/8bitclassics.com/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
        </Directory>
    
        # cgi enabled
        ScriptAlias  /cgi-bin/ /var/clients/client1/web2/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
            php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@8bitclassics.com"
        php_admin_value upload_tmp_dir /var/clients/client1/web2/tmp
        php_admin_value session.save_path /var/clients/client1/web2/tmp
        #php_admin_value open_basedir /var/clients/client1/web2:/usr/share/php5
    
    php_admin_value memory_limit 64M
    </VirtualHost>
    
    
    <IfModule mod_ssl.c>
    ###########################################################
    # SSL Vhost
    ###########################################################
    
    <VirtualHost 172.21.152.31:443>
          DocumentRoot /var/www/8bitclassics.com/web
    
        ServerName 8bitclassics.com
        ServerAlias www.8bitclassics.com
        ServerAdmin webmaster@8bitclassics.com
    
        ErrorLog /var/log/ispconfig/httpd/8bitclassics.com/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        SSLEngine on
        SSLCertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.crt
        SSLCertificateKeyFile /var/clients/client1/web2/ssl/8bitclassics.com.key
        SSLCACertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.bundle
    
        # cgi enabled
        ScriptAlias  /cgi-bin/ /var/clients/client1/web2/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
            php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@8bitclassics.com"
        php_admin_value upload_tmp_dir /var/clients/client1/web2/tmp
        php_admin_value session.save_path /var/clients/client1/web2/tmp
        #php_admin_value open_basedir /var/clients/client1/web2:/usr/share/php5
    
    php_admin_value memory_limit 64M
    </VirtualHost>
    </IfModule>
    
    
    default

    Code:
    NameVirtualHost *
    NameVirtualHost *:80
    <VirtualHost *>
            ServerAdmin webmaster@localhost
    
            DocumentRoot /var/www/
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog /var/log/apache2/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog /var/log/apache2/access.log combined
            ServerSignature On
    
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    
    </VirtualHost>
    
     
  6. koltz

    koltz New Member

    Bump, see above message.
     
  7. till

    till Super Moderator

    You still have not done what I told you in post #21 of this thread! If you dont do what we tell you, your setup will never get working.
     
  8. koltz

    koltz New Member

    Umm, I did. Now if you wanted me to do 21 with the other last post you didn't specify. 21 by itself doesn't do anything different as mentioned in my post underneath it. I will try 21 with recreating the SSL.
     
  9. koltz

    koltz New Member

    After I make the changes from post 21, it adds this to my site:

    Code:
    <IfModule mod_ssl.c>
    ###########################################################
    # SSL Vhost
    ###########################################################
    
    <VirtualHost 172.21.152.31:443>
          DocumentRoot /var/www/8bitclassics.com/web
    
        ServerName 8bitclassics.com
        ServerAlias www.8bitclassics.com
        ServerAdmin webmaster@8bitclassics.com
    
        ErrorLog /var/log/ispconfig/httpd/8bitclassics.com/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        SSLEngine on
        SSLCertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.crt
        SSLCertificateKeyFile /var/clients/client1/web2/ssl/8bitclassics.com.key
        SSLCACertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.bundle
    
        # cgi enabled
        ScriptAlias  /cgi-bin/ /var/clients/client1/web2/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
            php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@8bitclassics.com"
        php_admin_value upload_tmp_dir /var/clients/client1/web2/tmp
        php_admin_value session.save_path /var/clients/client1/web2/tmp
        #php_admin_value open_basedir /var/clients/client1/web2:/usr/share/php5
    
    php_admin_value memory_limit 64M
    </VirtualHost>
    </IfModule>
    
    
    Apache2 fails to restart once the SSL cert is created, here is what Apache2 says when loading

    Code:
     * Restarting web server apache2                                                                                                                             [Thu Feb 26 13:05:01 2009] [warn] NameVirtualHost 172.21.152.32:443 has no VirtualHosts
    [Thu Feb 26 13:05:01 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
    httpd (pid 26994?) not running
    [Thu Feb 26 13:05:11 2009] [warn] NameVirtualHost 172.21.152.32:443 has no VirtualHosts
    [Thu Feb 26 13:05:11 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
    [fail]
    
    When I delete the SSL Vhost stuff added, the site starts running again.
     
  10. falko

    falko Super Moderator

    Can you post all the NameVirtualHost lines from your Apache configuration?
     
  11. koltz

    koltz New Member

    In the httpd.conf file, i just have one line in the whole file:

    Code:
    NameVirtualHost *:80
    
    Nothing in the apache2.conf file.
     
  12. koltz

    koltz New Member

    I just tried it again and this time looked at apache2 error.log after it wouldn't restart. Here is the error:

    Code:
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/htscanner.so' - /usr/lib/php5/20060613+lfs/htscanner.so: cannot open shared object file: No such file or directory in Unknown on line 0
    
     
  13. koltz

    koltz New Member

    Maybe it would be beneficial for me to see what a known working default and vhost file with SSL enabled looks like? Are you able to post yours with SSL enabled for me to look at and see what differences there are?
     
  14. till

    till Super Moderator

    This is a php module which you installed and were a file is missing, this is nothing ispconfig related. Either you reinstall this php module so that the .so file is there or you remove it from the php configuration.
     
  15. koltz

    koltz New Member

    Can you post actual default and vhost files that have SSL enabled?
     
  16. till

    till Super Moderator

    You can find the templates for the vhost file here:

    /usr/local/ispconfig/server/conf/vhost.conf.master

    It contains also the ssl part.
     
  17. koltz

    koltz New Member

    Well got it working. Looking at the instructions (for Ubuntu), it doesn't look like there is anything in it for adding SSL besides the module and enabling it. I had to create the local certs using openssl, copied /etc/apache2/sites-available/default to /etc/apache2/sites-available/ssl, making a link to /sites-enabled. I then changed in the ssl file

    from:
    Code:
    NameVirtualHost *:80
    <VirtualHost *:80>
    
    to:
    Code:
    NameVirtualHost *:443
    <VirtualHost *:443>
    
    and added to following underneath the DocumentRoot line:

    Code:
            SSLEngine on
            SSLCertificateFile /etc/ssl/certs/server.crt
            SSLCertificateKeyFile /etc/ssl/private/server.key
    
    I created the CRT and KEY files with openssl and installed them in the above paths. I restarted apache and got my SSL working for my site. Getting the local cert created then I had to figure out getting the GoDaddy cert in there, but finally did that last night.
     

Share This Page