Issues with FTP and accessing site

Discussion in 'General' started by Ganther, Dec 10, 2007.

Thread Status:
Not open for further replies.
  1. Ganther

    Ganther New Member

    Finally I am able to get Fedora and ISPconfig working and have created a site. My setup is basic 1 server and 1 Winxp box behind a linksys router.

    But I am having couple of issues and was hoping to get some help I am a newbie with both Fedora and ISPconfig.

    1. I can only access my site that I have created in ISPconfig using HTTPS and not HTTP. How can I fix this so that I can view the site using HTTP? right now I get a shared ip page with HTTP, HTTPS I get the fedora test page.

    2. I can access the site via Web-FTP but I can not setup up dreamweaver to ftp to my site I am using and I have tried either way I get cannot connect to host. user name I use the web2_name.

    any help would be great.. thanks
  2. Hans

    Hans Moderator ISPConfig Developer

    Please check if your apache is listening to port 80 (http) and 443 (https) as well.
    Waht is the output of: netstat -tap

    Within Dreamweaver, if you select "FTP" within the "Access" field do not mention "ftp://" again within the field "FTP host" again. So not "ftp://mydomain.tld" but only "mydomain.tld"
    Specify "/web" within the "Host directory"

    Within try to establish a connection within "Passive mode" and "Normal" mode.
    To enable "Passive mode", you have to swith to the advanced mode within the wizard.
    Last edited: Dec 10, 2007
  3. Ganther

    Ganther New Member

    here is the netstat -tap was not sure how to check to see if apache is listening on port 80 or not.

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:49985 *:* LISTEN 1787/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 2099/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1768/rpcbind
    tcp 0 0 *:hosts2-ns *:* LISTEN 2534/ispconfig_http
    tcp 0 0 *:* LISTEN 14206/named
    tcp 0 0 *:* LISTEN 14206/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 14206/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2283/cupsd
    tcp 0 0 localhost.localdomain:smtp *:* LISTEN 14442/sendmail: acc
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 14206/named
    tcp 1 0 CLOSE_WAIT 32643/python
    tcp 0 0 *:http *:* LISTEN 2557/httpd
    tcp 0 0 *:ftp *:* LISTEN 14406/proftpd: (acc
    tcp 0 0 *:ssh *:* LISTEN 1995/sshd
    tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 14206/named
    tcp 0 0 *:https *:* LISTEN 2557/httpd
    tcp 0 148 ::ffff: ESTABLISHED 431/0

    As for the FTP I tried what you suggested domain.tld with the web2_username and /web as the host directory I tried it in passive mode as well, it is saying that the host can not be found.
  4. Ganther

    Ganther New Member

    Got the HTTP part working added it to my host file on my xp box I tried the same with the ftp but no go.
  5. Hans

    Hans Moderator ISPConfig Developer

    If your server is behind a router did you forward port 21 from your public IP to the internal IP of your server?

    Can you establish a FTP-connection when you use the IP-address instead of the domain name?
  6. Ganther

    Ganther New Member

    I did not forward port 21, I figured I didn't need to since this server is not hosting live sites and both the server and the xp box are behind the router.

    I will give that a shot today and see if it makes a difference.

    I tried accessing the ftp with the internal IP address it still would not connect.
  7. Ganther

    Ganther New Member

    Hans thanks for the help you pointed me in the direction I needed to look, if I use domain.tld or the eth0:0 ip address ftp does not work.

    If I use the main ip address of the server with the web2_username I am able to access the ftp from my xp box I tried DOS, Dreamweaver and one other client and they all work.

    I am thinking I need to add an entry to my hosts file on my xp box and on the server so when I use doamin.tld it point to my servers main ip address.

    Thanks again for the help.
  8. Hans

    Hans Moderator ISPConfig Developer

    Yes you're right. I'm glad you did it. :)
Thread Status:
Not open for further replies.

Share This Page