Issues with dummy slave

Discussion in 'Installation/Configuration' started by mkreder, Mar 2, 2012.

  1. mkreder

    mkreder New Member

    Hi,

    I've installed ispconfig 3.0.4.3 as master/slave in Centos 6.2. Master was installed first, I've created a couple of DBs, sites, and DNS records.
    Then, I installed the same version on the slave node, gave it the master root mysql password and the installation went just fine.
    In both cases, I used root mysql users as indicated in the HowTo during the setup.
    Now the issues is that if I create a site in the master panel but using the slave server as server, it does nothing, it appears in the master panel as green but it never shows up in the slave server nginx configuration.
    If I log into the slave web panel, I don't see this site create neither any other site in the master it looks like an empty server.
    If I go to the DNS sync tool in the slave server it doesn't find any record to replicate.
    Looks like the slave server is not pulling the information from the master mysql database.

    I tried to find errors in /var/log/ispconfig/ispconfig.log but they are empty..
    any idea?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are there any errors in ISPConfig's Monitor module?

    It works fine for me (also with nginx, but on Debian Wheezy).

    Did you disable SELinux?
     
  3. mkreder

    mkreder New Member

    Nothing in the monitor module:

    For the slave node it shows:

    Code:
    CPU Info (Server : lglass.example.com)
    
    Data from: ????-??-?? ??:??
    
    No data about the CPU available at the moment. Please check again later.
    from both the master and the slave. And nothing in the "system-log"

    SELinux is disabled for me, I running both the master and slave in OpenVZ containers.
     
  4. mkreder

    mkreder New Member

    Issue looks solved by following this:
    http://www.howtoforge.com/forums/archive/index.php/t-48659.html

    the key was: "Login to ispconfig on the master server, go to the server settings of the slave server and select that this server is a slave server of the master. The settings is named "is mirror of". This new setting will only affect new created domains or updated domains."

    Haven't find that before
     
  5. mkreder

    mkreder New Member

    Well, this is a little bit confusing... Now I cannot create sites in the slave because it is mirrored with the master.. But I don't get the mirror concept here.

    The mirror only mirrors the conf? not the database or the web directory?
    In some forums it says that the master/slave conf was to manage all the servers from 1 sigle panel. I would like this feature more that mirroring just the conf.

    I just need DNS mirroring...

    Could someone clarify please?
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes. For the mirroring configuration that includes the database and the web directory see mirro setup guides.

    http://www.howtoforge.com/installin...tabase-cluster-on-debian-6.0-with-ispconfig-3

    Thats the default and you disabled it by switching to mirror mode. So to get the faeture back, disable mirroring under system > server services.
     

Share This Page