Issues With Clients Creating Databases

Discussion in 'Installation/Configuration' started by crypter, Oct 11, 2013.

  1. crypter

    crypter New Member

    Hey guys, I'm hoping to get some assistance with an issue I'm having. It basically has to do with clients and databases.

    I believe ISPConfig is communicating just fine with MySQL, because when I make any configuration changes, add domains/users/, etc, everything works fine.

    These are the steps I've taken, so I'm not entirely sure where I've gone wrong. All these steps were performed under the Client's login and not the admin long.

    1) Created database user "fluxuser" and password "fluxpwd"
    2) Created database "fluxbb" using "fluxuser" as the user
    3) Navigated to FluxBB's install.php
    4) Ran install using "localhost", "fluxbb" as the DB, "fluxuser" as DB user, and "fluxpwd" as DB user password.
    5) I receive this error:

    Code:
    Error: Unable to connect to MySQL and select database. MySQL reported: Access denied for user 'fluxuser'@'localhost' (using password: YES).
    So as I said I'm not sure where it's going wrong. Does anyone have any insight on what could be causing the issue? If anymore information is needed, please let me know. Thanks!

    PS: I followed the Perfect Server (CentOS 6.4) guide
     
  2. crypter

    crypter New Member

    I found out the problem. Posting the solution in case anyone else needs it.

    The MySQL password in my ISPConfig configuration file wasn't correct. I may have changed the password after installing ISPConfig... I can't remember.

    Anyway the config file needing edited is located below and the password is in plain text:

    Code:
    /usr/local/ispconfig/server/lib/mysql_clientdb.conf
     

Share This Page