Issues with autoresponder

Discussion in 'Installation/Configuration' started by Chris23, Dec 13, 2018.

  1. Chris23

    Chris23 New Member

    Hi,

    Having issues with the autoresponder adding the your mail to the top of the reply message instead of the auto reply.
    I have added the -N tag to the autoresponder.master file, but it does not seem to be working :
    # The following must be one contiguous line
    cc "| mailbot -N -t $RESPOND -d $RESPONDDB -c 'UTF-8' -D 1 \
    -A 'From: $RECIPIENT' -s 'Auto Response: from $RECIPIENT' \
    /usr/sbin/sendmail -t -f ''"

    Any help will be appreciated.

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure you use courier on your server and not dovecot? The file you edited is for courier mail servers only.
     
  3. Chris23

    Chris23 New Member

    According to the server, it should be running courier.
    ● postfix.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)
    /usr/local/ispconfig/server/conf# service dovecot status
    ● dovecot.service
    Loaded: not-found (Reason: No such file or directory)
    Active: inactive (dead)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then you edited the right file. But postfix must be installed as that#s the only smtp server supported by ISPconfig. Courier systems are not very common anymore for ispconfig systems, that's why I asked. Did you check if your modification has been written correctly into the autoresponder file of the mailbox?
     
  5. Chris23

    Chris23 New Member

    I had a look to see if the autoresponder wrote to this dir /var/vmail/mailfilters/, but it was empty.
    Does it write it somewhere else?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    use

    ls -la

    the file starts with a dot.
     
  7. Chris23

    Chris23 New Member

    [email protected]:/var/vmail/mailfilters# ls -lah
    total 8.0K
    drwxr-xr-x 2 root root 4.0K Oct 13 2016 .
    drwxr-xr-x 3 vmail vmail 4.0K Dec 13 10:56 ..
    [email protected]:/var/vmail/mailfilters# cd ..
    [email protected]:/var/vmail# ls -lah
    total 32K
    drwxr-xr-x 3 vmail vmail 4.0K Dec 13 10:56 .
    drwxr-xr-x 15 root root 4.0K Mar 29 2017 ..
    -rw-r--r-- 1 vmail vmail 220 Nov 13 2014 .bash_logout
    -rw-r--r-- 1 vmail vmail 3.5K Nov 13 2014 .bashrc
    -rw------- 1 vmail vmail 1.5K Oct 13 2016 .mailfilter
    -rw-r--r-- 1 root root 1.5K Oct 13 2016 .mailfilter~
    drwxr-xr-x 2 root root 4.0K Oct 13 2016 mailfilters
    -rw-r--r-- 1 vmail vmail 675 Nov 13 2014 .profile
    [email protected]:/var/vmail#
     
  8. Chris23

    Chris23 New Member

    Anything else I can try?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look into the generated mailfilter file, it is in mailfilters/domain/user/ subdirectory
     
  10. Chris23

    Chris23 New Member

    As before there is nothing in the folder mailfilters, it is a blank directory.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you used 'ls -la'? The files start witha dot, you will not see them otherwise.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    And please post the result of:

    ps aux | grep courier
     
  13. Chris23

    Chris23 New Member

    I have, I sent this in my previous reply :

    [email protected]:/var/vmail/mailfilters# ls -lah
    total 8.0K
    drwxr-xr-x 2 root root 4.0K Oct 13 2016 .
    drwxr-xr-x 3 vmail vmail 4.0K Dec 13 10:56 ..
    [email protected]:/var/vmail/mailfilters# cd ..
    [email protected]:/var/vmail# ls -lah
    total 32K
    drwxr-xr-x 3 vmail vmail 4.0K Dec 13 10:56 .
    drwxr-xr-x 15 root root 4.0K Mar 29 2017 ..
    -rw-r--r-- 1 vmail vmail 220 Nov 13 2014 .bash_logout
    -rw-r--r-- 1 vmail vmail 3.5K Nov 13 2014 .bashrc
    -rw------- 1 vmail vmail 1.5K Oct 13 2016 .mailfilter
    -rw-r--r-- 1 root root 1.5K Oct 13 2016 .mailfilter~
    drwxr-xr-x 2 root root 4.0K Oct 13 2016 mailfilters
    -rw-r--r-- 1 vmail vmail 675 Nov 13 2014 .profile
    [email protected]:/var/vmail#
     
  14. Chris23

    Chris23 New Member

    Apologies, the issue seems to be that I completely forgot i'm running a multi server setup and mail is split from the control panel.
    Just assumed that it will read the conf file from the control panel and push to the mail server.
    I added the -N tag in the global settings, do I need to restart courier?
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to alter the autoresponder of that mailbox, e.g. change the time or alter the text slightly and save it. And yes, the master template must be altered on the mail server.
     

Share This Page