Issues with attempting to upgrade to Jessie from Wheezy

Discussion in 'General' started by tmpinsnty, Feb 28, 2018.

  1. tmpinsnty

    tmpinsnty Member HowtoForge Supporter

    Hello,
    I have a server that should be a "Perfect Server Wheezy, Apache, PHP" edition. I am attempting to upgrade to Jessie to stay in compliance. I have tried three times so far following various tutorials found on this site and others.
    My first try I couldn't get it to reboot after the upgrade. This was actually following the Debian site's upgrade.

    Since I use iSPConfig I started digging through the site and found the tutorial and this mini how-to: https://www.howtoforge.com/communit...fig3-debian-wheezy-to-jessie-in-openvz.70071/
    So for my second attempt I used these.
    My first problem was that attempting to install sysvinit with the Wheezy repositories, it can't find the package. So I changed the repositories to Jessie to install this and uninstall systemd and fail2ban.
    After going through the update, Apache wouldn't start. I figured it might be because of the need to reconfigure services with the manual update of ISPconfig. Well so I did that and I was not able to log into my ISPconfig dashboard. I got no HTTP error message, just a couldn't contact error.

    When I did the Apache2 config test I would get an error about a syntax issue on line 140 of the apache2.conf file. So I did some changes until I got it right. I also had some cloudflare.load syntax issues but no joy there. I still couldn't get into my dashboard.
    Should I have rebooted again? I just restarted apache2 by "/etc/init.d/apache2 restart"

    One clarification needed for the Tutorial for Wheezy to Jessie, do we keep existing config files or let them update it? I read in place (which I can't find now) that yes go ahead a change them. Then I read another post (till's) that says don't change them. That doing the ISPconfig update would fix them.

    I tried both ways. Monday I did the changing them and Tuesday I didn't change them. Same problem, can't get ISPconfig dashboard to come up.

    Tuesday's attempt at update ISPconfig stopped when it couldn't find /var/run/mysqld/ socket and wouldn't log into mysql. So I went to the Perfect Server instructions for Jessie and found the install for mysql. Once I installed it I got it to finish re-configuring services. But still couldn't get into ISPconfig dashboard.

    Should I have rebooted here?

    I tried to find the "before you post" type post to see what I needed to put in this thread for information. I attempted to run the htf script last night and it couldn't find one of the files. At that point it was getting too late and so I just reload the snapshot and went to bed.

    Can you guys give me some more commands and scripts to test out to help me figure out what I need to do for this upgrade?
    (Oh FYI I have ISPProtect also)
    Thanks in advance.
     
    Last edited: Feb 28, 2018
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    But you got the ISPConfig login screen? In that case, you might have to empty the browser cache and delete cookies in the browser. Cached old js or html files or an old ongoing session might prevent login after an ISPconfig upgrade.
     
  3. tmpinsnty

    tmpinsnty Member HowtoForge Supporter

    No log in screen just the chrome error screen.
    I did empty my browser cache but not delete the cookies.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you did not get a login screen at all, then there must have been a different issue.
     
  5. tmpinsnty

    tmpinsnty Member HowtoForge Supporter

    Any other hints of hat I could try to find out what's happening?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you check the apache error.log file?
     
  7. tmpinsnty

    tmpinsnty Member HowtoForge Supporter

    Yes. The log file is unfortunately on my home computer. And I can't remember anything specific or significant right now.
     
  8. tmpinsnty

    tmpinsnty Member HowtoForge Supporter

    OK, Log acquired. Would you like me to upload it or is there anything I should be looking for?
     
  9. SamTzu

    SamTzu Member

    If I remember correctly each site had to be modified during upgrade. Something changed in Apache config back then and all .vhost files had to be re-generated by ISPconfig. Most likely the old apache 2.2 syntax in the sites, use the ispconfig resync function to convert it to 2.4 syntax:
    Try:
    systemctl status apache2.service
     
    Last edited: Mar 16, 2018

Share This Page