Issue with Postfix using "Perfect CentOS 5.3" setup

Discussion in 'Server Operation' started by varius, Nov 24, 2009.

  1. varius

    varius New Member

    Hi guys,

    I just installed a fresh CentOS 5.3 server following the ISPConfig-3 guide to make the "Perfect Server". Everything seemed to work like a charm.

    However, I am having issues with sending out mail. Here is the situation:

    I have multiple IPs on my server ( usable). I setup my hostname as pointing to IP The problem I am having, is mails being sent out are treated as coming from .10 not .14 like I would like.

    Here is an example from GMail headers:

    Received: from ( [])
    by with ESMTP id 30si10032486yxe.54.2009.;
    Mon, 23 Nov 2009 23:54:18 -0800 (PST)

    As you can imagine, as it's seeing it sent from .10, it's failing the SPF check.

    How can I change the configuration so that Postfix sends out on .14 or uses the hostname, instead of .10 ?

    I have tried setting the config option

    smtp_bind_address =

    in my /etc/postfix/, however then it fails to bind and gives me the following error:

    postfix/smtp[16423]: warning: smtp_connect_addr: bind Cannot assign requested address

    as well as

    amavis[1550]: (01550-20) (!!)WARN: all primary virus scanners failed, considering backups

    That makes me think it may be some sort of Postfix/amavisd conflict, perhaps.

    I've spent hours on this, Googling and researching and have gotten nowhere ;/

    Any help will be greatly appreciated, I am certain it must be something simple!

  2. varius

    varius New Member

    Well I could not solve this, so I just reversed the order of IPs on my server so .14 is first; works fine. Not the proper solution, but I guess it's the only option at this time.

Share This Page