Issue with last update[Solved]

Discussion in 'General' started by Chris H, Feb 13, 2017.

  1. Chris H

    Chris H New Member

    When I go to any of the domains I have set up for my sites I am getting the default ispconfig page.
    Looking on my server's directories I see that there is a new folder under /var/www/clients/client1/ called web2 which has nothing in it but a index file, which if I alter I see those changes when going to any of my sites.
    All of my content is in /var/www/clients/client1/web1/web which is not loading.
    Looking in ispconfig the document root directory for my site is /var/www/clients/client1/web1

    I am not sure what happened, maybe I chose the wrong option when I did the latest update to ispconfig. Any suggestions on how to fix this?
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    check the ip address of your sites, see if 'web2' one has an ip set but your other domains have '*'
     
  3. Chris H

    Chris H New Member

    You were right, the sites ip was * I selected the server IP from the drop down. However things have not improved, now pages will not load at all. Browsers give an SSL error now. I was using lets encrypt integrated with ispconfig, I have disabled SSL in ISPconfig but still same issue pages are not loading and the browser keeps re-directing to https. Should I just burn this to the ground and start over?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If your site uses ssl and has a http to https redirect enabled, then it will not work unless you turn on ssl again.
    Regarding IP, do not mix IP and * on your server, either use for all sites or use the IP for all sites.
     
  5. Chris H

    Chris H New Member

    I did have both SSL and HTTPS Redirect enabled, since my site started giving me an ssl error I thought maybe there was an issue with the cert so I disabled both. Today I thought to double check or try to enable them again but for some reason I can not locate the HTTPS redirect setting again :/ I am not exactly new to ISPconfig and feeling a bit dumb right now.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The https redirect setting is on the redirect tab, but it is shown only when ssl is on. switch on ssl for the site and then go to the redirect tab to disable it, afterwards you can disable ssl again.
     
  7. Chris H

    Chris H New Member

    After I re-enabled SSL, LetsEncrypt and HTTPS redirect everything is back to normal. This was pretty weird thank you very much for the assistance!
     

Share This Page