issue sending

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Feb 26, 2015.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good Day,
    The server isn't sending emails. It doesn't work from environment (PHP). I did a simple shell mail test and it is deferred:

    # less /var/log/maillog
    Feb 26 15:52:23 hote3 postfix/smtpd[25020]: connect from localhost.localdomain[127.0.0.1]
    Feb 26 15:52:23 hote3 postfix/smtpd[25020]: warning: SASL: Connect to private/auth failed: Connection refused
    Feb 26 15:52:23 hote3 postfix/smtpd[25020]: fatal: no SASL authentication mechanisms
    Feb 26 15:52:24 hote3 postfix/master[835]: warning: process /usr/libexec/postfix/smtpd pid 25020 exit status 1
    Feb 26 15:52:24 hote3 postfix/master[835]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Feb 26 15:52:24 hote3 sendmail[25019]: t1QKqN6o025019: to=[email protected], ctladdr=root (0/0), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30222, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection reset by [127.0.0.1]
    Feb 26 15:53:36 hote3 clamd[749]: SelfCheck: Database status OK.

    I seem to have an issue with Dovecot?
    # service dovecot restart
    Stopping Dovecot Imap: [FAILED]
    [[email protected] ~]# service postfix restart
    Shutting down postfix: [ OK ]
    Starting postfix: [ OK ]

    Any hint on how I approach this?

    Thanks ahead,
    JP Cyrenne
     
  2. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Don't know what I had done.
    I had the classic redundant symlink issue between /etc/dovecot.conf and /etc/dovecot/dovecot.conf (linking to each other).

    [email protected] dovecot]# service dovecot start
    Starting Dovecot Imap: [ OK ]
    [[email protected] dovecot]# service dovecot restart
    Stopping Dovecot Imap: [ OK ]
    Starting Dovecot Imap: [ OK ]
    [[email protected] dovecot]# service postfix restart
    Shutting down postfix: [ OK ]
    Starting postfix: [ OK ]

    My test mail worked... I seem to be good.

    Can I rest assured that the differed emails will all go out? The site went in production this morning.

    Thanks,

    JP
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Emails will go out automatically. Or you force that with:

    postqueue -f
     

Share This Page