Issue sending email to same domain

Discussion in 'Installation/Configuration' started by olimortimer, Oct 14, 2015.

  1. olimortimer

    olimortimer Member

    I have my ISPConfig 3.0.5.4p8 server (Ubuntu 14.04) setup to relay all my email through smtp-relay.gmail.com (set as relayhost in Server Config > Mail). This all works fine, and delivers email ok. However, I've noticed that when an email is generated from a domain to itself, the email is never delivered (for example, an e-commerce site that generates email to myself when orders are placed). Looking into the mail log, the follow is an example:

    Code:
    Oct 14 19:29:54 local postfix/pickup[17941]: F0599C1F51: uid=5022 from=<[email protected]>
    Oct 14 19:29:54 local postfix/cleanup[21207]: F0599C1F51: message-id=<[email protected]>
    Oct 14 19:29:54 local postfix/qmgr[1388]: F0599C1F51: from=<[email protected]>, size=1803, nrcpt=2 (queue active)
    Oct 14 19:29:55 local postfix/pipe[21212]: F0599C1F51: to=<[email protected]>, orig_to=<[email protected]>, relay=dovecot, delay=0.05, delays=0.02/0.01/0/0.03, dsn=5.1.1, status=bounced (user unknown)
    Oct 14 19:29:55 local postfix/smtp[21213]: connect to smtp-relay.gmail.com[2a00:1450:400c:c02::1c]:25: Network is unreachable
    Oct 14 19:29:55 local postfix/smtp[21213]: F0599C1F51: to=<[email protected]>, relay=smtp-relay.gmail.com[74.125.206.28]:25, delay=0.62, delays=0.02/0.02/0.39/0.19, dsn=2.0.0, status=sent (250 2.0.0 OK 1444847395 e6sm520135wiy.4 - gsmtp)
    Oct 14 19:29:55 local postfix/cleanup[21207]: 90B63C20CA: message-id=<[email protected]>
    Oct 14 19:29:55 local postfix/qmgr[1388]: 90B63C20CA: from=<>, size=3710, nrcpt=1 (queue active)
    Oct 14 19:29:55 local postfix/bounce[21219]: F0599C1F51: sender non-delivery notification: 90B63C20CA
    Oct 14 19:29:55 local postfix/qmgr[1388]: F0599C1F51: removed
    Oct 14 19:29:55 local postfix/pipe[21212]: 90B63C20CA: to=<[email protected]>, orig_to=<[email protected]>, relay=dovecot, delay=0.01, delays=0/0/0/0.01, dsn=5.1.1, status=bounced (user unknown)
    Oct 14 19:29:55 local postfix/qmgr[1388]: 90B63C20CA: removed
    Does anyone have any idea on how to fix this please?
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

  3. olimortimer

    olimortimer Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    domain.co.uk may not be added as email domain on this server when it is hosted at google.
     
  5. olimortimer

    olimortimer Member

    Ah yeah, so I have domain.co.uk still added as an email domain within ISPConfig. Removing that should fix it? Must have been left there from when I moved from server hosted to Google hosted.
     

Share This Page