[issue] missing proxy_http when enable proxy in ispconfig

Discussion in 'General' started by Ruthwen, Jul 22, 2021.

  1. Ruthwen

    Ruthwen New Member

    Hi.
    I found a issue in ISPconfig, tested on 3.2.2, 3.2.4 and 3.2.5.

    Problem:
    missing: a2enmod proxy_http before reload apache

    How to reproduce on Debian10:
    1. On clear installation (or without proxy enabled) of ispconfig go: websites -> web domain -> options
    2. Check the "Enable PROXY Protocol" box
    3. In textarea apache directives add:
    Code:
    ProxyRequests off
    <Proxy *>
      Order deny,allow
      Allow from all
    </Proxy>
    <Location />
      ProxyPass http://localhost:3000/
      ProxyPassReverse http://localhost:3000/
    </Location>
    
    4. Click SAVE.
    5. Run anything on localhost:3000, for example redmine in docker:
    Code:
    docker run -ti -d -p 3000:3000
    6. Go to your site

    Without:
    Code:
    a2enmod proxy_http && systemctl restart apache2
    you get an error.

    Solution proposal:
    1. Add to reload procedure after enabling "Enable PROXY Protocol" the a2enmod proxy_http command.
    2. Enable apache proxy_http module during installation of ispconfig.

    I think 1-st is better.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page