ISPCongfig not responding

Discussion in 'Installation/Configuration' started by SiMiE, May 22, 2007.

  1. SiMiE

    SiMiE New Member

    Hi all,

    I have just installed ISPConfig and everything went ok and all was working fine, until suddenly it stopped working...

    The URL you use to get to the CP doesn't work. All i have done after the install was change the admin password and added a site - that doesn't work either

    Everything is seems to be up and running ok. i.e ISPConfig, Apache and MySQL

    Although, I can get to my localhost website address

    Any ideas why it just stopped working?

    Any help will be great!!

  2. SiMiE

    SiMiE New Member

    Not to worry

    Sorted it now... Somehow??? :confused:

  3. SiMiE

    SiMiE New Member

    Maybe not then... i can access the CP from using the IP:81 - which is fine!

    But i can not access any of my sites URL's??
  4. edge

    edge Active Member Moderator

    If you are trying to access the domains within your private network, than one option to access it, is to add the IP and DOMAIN to the HOSTS file of the PC that you are using to access the domain.

    In Windows the hosts file is located in c:\windows\system32\drivers\etc

    Make sure that you restart your browser to read the new hosts file
    Last edited: May 22, 2007
  5. SiMiE

    SiMiE New Member

    Yeh i've had a look at my HOSTs file, it all looks ok.

    ATM i will only want to access internally but eventually externally

    Using Fedora Core 6 BTW :cool:
    Last edited: May 22, 2007
  6. edge

    edge Active Member Moderator

    So the fedora core is on the PC that you are using to access the "local" website.

    If so, your hosts looks fine (I think). That is, if is your LAN IP of the server, and is the domain.

    Are you still having the problem accessing within your LAN?
  7. SiMiE

    SiMiE New Member

    Yes my sites are on fedora and i can access on that computer but not on another computer on my local network...

    But if i create a new site in ISPConfig called i cannot access that either on my fedora server nor any of my other pcs...

    Also, I cannot access the ISPConfig CP from anyother computer either!!

    I only have a single ip for my server which if i goto that i get the ISPConfig page stating that it is a shared ip - so type the web URL instead which is correct

    I have looked at my router settings and i have added the port fowardings for ports like 80 and 81 etc... to point to my servers static ip
  8. edge

    edge Active Member Moderator

    You will need to add: " simie" to all hosts files on every PC on your LAN.
    (you need to do the same for any other domain that you create, and that you want to access within your LAN)

    Again make sure that is the LAN IP of the server.

    The HOSTS file on all othe LAN PC's will tell the PC that (or whatever other domain) is on:
    Last edited: May 22, 2007
  9. SiMiE

    SiMiE New Member

    Yeh, i would think this would work, but i dont think it should be required... because if i get the websites working externally to the LAN, i.e. WAN, this wont be required
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    If you dont want to edit yor hosts file, you need valid DNS records for your domains pointing to your server.
  11. SiMiE

    SiMiE New Member

    Ok, but why doesn't my work externally that should work right?? (based on my previous posts)

    Then when i create a a site in ISPconfig, that will just add an extra vhost and go to that site when the sub-domain is entered in the URL

    Are these the only things it need to check are setup correctly?

    - Router port forwarding for 80 and 81 - (Others for mail etc...)
    - DynDns IP is correct
    - Hosts file on Server
    - Static IP for server correct
    - Services all running (httpd, mysql etc...)
    - Apache config file
    - Apache/ISPConfig vhost file for sub-domains, i.e. sites

    Any other items i need to check??

  12. edge

    edge Active Member Moderator

    Maybe your IP changed, and it did not update at

    When I ping it resolves to an IP, but gives me a timeout

    Does your WAN IP end with 94.118?
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Additionally you should ask your internet provider if they block any ports.
  14. SiMiE

    SiMiE New Member

    Yes my IP does end in 94.118 and that is correct on dyndns. I have ddclient setup on my server which updates this for me automatically. Then i port foward it on my router to my server IP

    I have previously had this working on fedora and windows machines externally... so it doesn't look like my ISP has blocked these ports

  15. falko

    falko Super Moderator ISPConfig Developer

    Do you still use the same router? Because if you now use another router, it's possible that it doesn't support loopbacks.
    Also, did you disable SELinux on your server?
  16. SiMiE

    SiMiE New Member

    Yes i am using the same router as before... my router is a Linksys WRT300N

    and SELinux has been disabled. My setup is from, which says to disable it...

  17. falko

    falko Super Moderator ISPConfig Developer

    I can't connect to on port 80.
    Please check again if your router forwards port 80 to your server, and that no firewall is blocking port 80. Also, APache must be running on the server.

Share This Page