ISPConfig_Clean Theme Updated

Discussion in 'Tips/Tricks/Mods' started by dclardy, Mar 12, 2013.

  1. richi

    richi New Member HowtoForge Supporter

    By the time of adding my question it was Firefox 19.0.2, now i am using 20.0.1 and this issue still remains.

    I am using your latest Theme Version (authored April 01, 2013) and the latest ISPC 3.0.5.2....!
     
  2. dclardy

    dclardy New Member

    I have installed Firefox and fixed the issue.

    Firefox does not seem to like the unprefixed box-sizing parameter.
     
  3. richi

    richi New Member HowtoForge Supporter

    Perfect... Thank you!
    Now it is working as expected even with my Firefox browser :eek:
     
  4. jimmyk

    jimmyk New Member

    Dclardy, I have looked at your files but things were not that clear to me if I am honest. I am fine with static site CSS and HTML, but dynamics sites with scripts and php are more of a problem for me to follow. I intend to have another look at this over the weekend and hopefully I will be able to work this out as I am nearly there with the rest of the theme.
     
  5. dclardy

    dclardy New Member

    Create a folder in the templates folder for login. Inside of that login folder, you will see three files that you can change around some. This gives you the custom page.
     
  6. dclardy

    dclardy New Member

    All,

    I have added some more sections to my theme that I think are pretty cool. You will have to install this theme changes differently than those in the past. The instructions have been updated to reflect this. If you find any issues, please post an issue on GitHub. I don't check this forum everyday, but I am on GitHub!

    New Login Sidebar
    [​IMG]

    Theme Settings
    [​IMG]

    Category List
    [​IMG]

    Category Create/Edit
    [​IMG]
     
    Last edited: May 14, 2013
  7. dclardy

    dclardy New Member

    Two more images for you to see.

    App List
    [​IMG]

    App Create/Edit
    [​IMG]
     
  8. dclardy

    dclardy New Member

    There was a small issue with the CSS that was throwing an error. This has been addressed in the Repo.
     
  9. dclardy

    dclardy New Member

  10. dclardy

    dclardy New Member

    All,

    I have added support for the new web and mail quota areas. Please update!
     
  11. webguyz

    webguyz Member HowtoForge Supporter

    Very nice! I know how much work that must have been. Installed under 3.0.5.3 and everything seems to be working fine. Thank you for this and the other installers as well.
     
  12. zenny

    zenny Member

    Marvellous, but the side panel at login screen is blank with ISPConfig3+nginx

    @dclardy: Thanks for the marvellous theme that looks majestic!

    I installed the theme in the ISPConfig3+nginx using your debian-installer script, and all works fine except the side panel in the login screen has no links at all. See attached screenshot.

    What tweaks are needed further to add those links in the side panel of the login screen in ISPConfig3+nginx? Thanks in advance.
     
  13. dclardy

    dclardy New Member

    @zenny,

    I do not see a screenshot here, but I am guessing that you are talking about the links in the login screen. Those are under the system settings. When you get there, you should see a new section for the theme settings. You can add what you need to there.
     
  14. dclardy

    dclardy New Member

    You are welcome. I am glad that it helped some!
     
  15. vol4

    vol4 New Member

    Good theme - thanks!
    But, problem with fonts in google chrome:
    [​IMG]

    IE is ok:
    [​IMG]
     
  16. CK13

    CK13 New Member

    1. With "this folder" do you mean the folder inside the zip file (ISPConfig_Clean-3.0.5-master)?

    2.
    //** Themes
    $conf['theme'] = 'default';
    $conf['html_content_encoding'] = 'utf-8'; // example: utf-8, iso-8859-1, ...
    $conf['logo'] = 'themes/default/images/header_logo.png';

    Replace the red text with ispc-clean, right?
     
  17. vol4

    vol4 New Member

    Yes, it's right! :)

    You need copy only "interface" folder to /usr/loca/ispconfig and import the SQL file inside of the sql folder.
     
    Last edited: Feb 28, 2014
  18. CK13

    CK13 New Member

    Thanks, i managed to install it, but like you i have troubles with the font icons.
     
  19. dclardy

    dclardy New Member

    Can you tell me what version of Chrome you are using? I'm not having an issue with the fonts at this time.
     
  20. CK13

    CK13 New Member

    I use Opera 19 and i have tried Chrome 34 too, same thing.
    Works in Firefox 28 though.
     

Share This Page