ISPConfig_Clean Theme Updated

Discussion in 'Tips/Tricks/Mods' started by dclardy, Mar 12, 2013.

  1. dclardy

    dclardy New Member

    All,

    I have updated my theme that I did for 3.0.4.* to work with 3.0.5.*. I have also made some changes to make it cleaner. It is heavily based on the ISPConfig website, and I have pushed it out to GitHub.

    GitHub Repo

    I personally feel that it is a huge improvement over the current default theme.

    Here are some pics of it.

    [​IMG]

    [​IMG]

    [​IMG]
     
  2. dclardy

    dclardy New Member

    I went ahead and changed the login form some. The change is reflected in the image above.

    Now that you can make templates inside of the theme, it was super easy to do. Let me know any issues that you find. I will probably be moving this over to SASS/Compass in the next few weeks.
     
  3. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Theme is awesome! However, as long as the bug exists (you mentioned it within another topic (not saving setting)) I can't switch - but afterwards that's the way to go :)

    Personally I'm not a fan of the new login screen... but this is just my thought :)

    Thanks for this great work!
     
  4. dclardy

    dclardy New Member

    I will work on improving the login screen some. What do you not like about it? Too plain? I only spent about 10 minutes on it, and I am sure that I can make it better.

    Or do you like the default style? I could just add the new parts to my theme. I was changing some core stuff, and I didn't want to write that all out. I think the new template stuff will allow me to make the change just in my theme. I'll test it out later.
     
  5. dclardy

    dclardy New Member

    This issue has been solved. You can read about it in the other thread.

    http://www.howtoforge.com/forums/showthread.php?t=60940
     
  6. andypl

    andypl Member

    Warning on ISPConfig 3.0.5.1 file not found
    Code:
    Warning: include_once(/usr/local/ispconfig/interface/web/tools/lib/interface.d/tpl_ispc-clean.menu.php): failed to open stream: No such file or directory in /usr/local/ispconfig/interface/web/tools/lib/module.conf.php on line 35 Warning: include_once(): Failed opening '/usr/local/ispconfig/interface/web/tools/lib/interface.d/tpl_ispc-clean.menu.php' for inclusion (include_path='.:/usr/share/php') in /usr/local/ispconfig/interface/web/tools/lib/module.conf.php on line 35 
    
     
  7. dclardy

    dclardy New Member

    I'll try to track that down.
     
  8. dclardy

    dclardy New Member

    @andypl That error is due to the coding of ISPConfig 3. I think there should be a check to see if the file exists before it tries to load it, but it is not doing that at this time.

    I will create a bug in the tracker to get rid of it. Without it there, it is not an issue. It is checking for a theme configuration page that this theme will more than likely never have.

    Bug Id: 2806
    Thanks.
     
    Last edited: Mar 17, 2013
  9. dclardy

    dclardy New Member

    The fix that I provided was accepted from what I can see, but I think that the logic needs to be more complete.

    For one thing, we should check to see if the file is in the theme. I don't think that we should have to place the file in the ISPConfig3 directories. Then, we should check for it in ISPConfig3 directory. If it doesn't exist, then we should include nothing.

    Code:
    if ( file_exists(ISPC_WEB_PATH.'/themes/' . $_SESSION['s']['user']['app_theme'] . '/tools/lib/interface.d/tpl_' . $_SESSION['s']['user']['app_theme'] . '.menu.php')) {
    
    	include_once(ISPC_WEB_PATH.'/themes/' . $_SESSION['s']['user']['app_theme'] . '/tools/lib/interface.d/tpl_' . $_SESSION['s']['user']['app_theme'] . '.menu.php');
    
    } elseif ( file_exists(ISPC_WEB_PATH.'/tools/lib/interface.d/tpl_' . $_SESSION['s']['user']['app_theme'] . '.menu.php')) {
    
    	include_once(ISPC_WEB_PATH.'/tools/lib/interface.d/tpl_' . $_SESSION['s']['user']['app_theme'] . '.menu.php');
    
    } else { };
     
  10. nokia80

    nokia80 Member HowtoForge Supporter

    After update ispconfig i get this error

    The chosen theme is not compatible with the current ISPConfig version. Please check for a new version of the theme.
    The default theme as been activated automatically.


    thanks
     
  11. dclardy

    dclardy New Member

    To fix this, you should edit the ISPC_Version or ispconfig_version file to be 3.0.5.2

    I am pushing an update to the repo now.
     
  12. nokia80

    nokia80 Member HowtoForge Supporter

    hi

    thanks but now i get the same error

    and i can't select the theme
     
  13. dclardy

    dclardy New Member

    Can you reinstall the theme from the repo? It works fine for me.
     
  14. richi

    richi New Member HowtoForge Supporter

    Firefox 19 Browser Issue

    Hello Everybody,

    i do have an issue with rendering when using this nice theme with my default browser....

    firefox_ispconfig.jpg

    When switching over to Internet Explorer 10 everything is working as expected.

    ie10_ispconfig.jpg

    Any hints on how to solve this?
     
    Last edited: Apr 1, 2013
  15. nokia80

    nokia80 Member HowtoForge Supporter

    no i have download the theme again but the same error.
     
  16. nokia80

    nokia80 Member HowtoForge Supporter

    problem solved
     
  17. dclardy

    dclardy New Member

    What browser version? Are you using the latest version of the theme?
     
  18. nokia80

    nokia80 Member HowtoForge Supporter


    yes i use last version and firefox last version on exploder works fine
     
  19. jimmyk

    jimmyk New Member

    I downloaded your theme and tested it as I wanted to look at how you created the simplified and in my opinion much improved login screen.

    Using Firefox I also have the same css problem that is shown in the above image.

    The simplified login screen works really well. I just need to look at how you have achieved it so I can work out how to create similar simple rectangular login screen for my theme:)
     
  20. dclardy

    dclardy New Member

    @jimmyk Dod you look through the theme files on github? It is pretty apparent how it works. You have to create a folder for the module in your theme and add .htm files there. These override how it renders the pages.
     

Share This Page