ISPConfig3 without Spam/Virus-Check

Discussion in 'Installation/Configuration' started by Helmi, Oct 6, 2010.

  1. Helmi

    Helmi New Member

    Hello!

    Is it possible to deactivate spamassassin, amavisd and clamd for ISPConfig3 either on a per domain basis or for all domains at once? If so, how?

    Thank you.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You can switch off SpamAssassin and ClamAV for a whole domain or for a single email account by selecting "Uncensored" or "not enabled" from the Spamfilter field in either the domain for or the email account form.

    Please note that the setting for a single email account overrides the spamfilter setting of the mail domain (no matter what spamfilter level you chose for the mail domain; this is true even if you disabled the spamfilter for the mail domain), with one exception: If you choose to not enable the spamfilter for the email account, but the spamfilter is enabled for the mail domain, then the spamfilter setting of the mail domain is used for this email account. Use Uncensored to disable the spamfilter.
     
  3. Helmi

    Helmi New Member

    Thank you. And how to disable clamd?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The virus scan can be disabled in the spamfilter policys as well.
     
  5. Esbeeb

    Esbeeb New Member

    Hello everybody,

    I'm new to ISPconfig (I just installed 3.1.13, in Debian 9), so far I'm liking it. But Clamd consumes quite a lot of RAM, and my VPS server only has 1GB of RAM. How did I figure out clamd was hogging all my RAM? With the command:

    ps aux | awk '{print $6/1024 " MB\t\t" $11}' | sort -n

    In my incoming emails, I want to filter spam (thanks to spamassassin, via amavis), but I don't want to check for viruses whatsoever (and not even run clamd at all).

    I'm using Linux on my laptop, and I am moreso prone to SPAM, but viruses attached to emails don't really concern me. I'd prefer to save the RAM on my VPS server. Yes, I'm cheap. Guilty as charged.

    I stopped and disabled clamd with commands like:
    systemctl stop clamav-freshclam
    systemctl stop clamav-daemon
    systemctl disable clamav-freshclam
    systemctl disable clamav-daemon
    systemctl mask clamav-freshclam
    systemctl mask clamav-daemon


    I also commented out two paragraphs pertaining to clamav in:
    /etc/amavis/conf.d/15-av_scanners
    ...then restarted amavis with:
    systemctl restart amavis

    Within the ISPconfig web admin, I also went to "Email" -> "Spamfilter" -> "Policy", and defined a new "SpamFilter Policy", where "Virus Lover" and "Bypass Virus Checks" is "Yes", but "No" for everything else.

    Then I used this newly-defined SpamFilter Policy in "Email" -> "Domain" -> [mydomain.com] -> "SpamFilter" dropdown is set to my new SpamFilter policy.

    Likewise, I also chose this new SpamFilter Policy for my mail user(s) in "Email" -> "Email Accounts" -> "Email Mailbox" -> [[email protected]] -> "SpamFilter" dropdown is set to my new SpamFilter policy.

    When clamd was running, my server would idle at about 800 of my 1000MB of RAM all used up! With clamd not running, Now it idles at 250MB. Ahhh, that's much better.

    If there's anything that I did here that will run afoul of ISPconfig itself, please let me know.
     
    Last edited: Jan 25, 2019
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is there no swap on that VPS host? If you put 3 GB swap you have 4 GB virtual memory, which should be enough for your mail server even when scanning for viruses.
     

Share This Page