ispconfig3 web / mysql on different servers does not work

Discussion in 'Installation/Configuration' started by captnnuss, Jul 27, 2009.

  1. captnnuss

    captnnuss New Member

    Hi there,

    I have an installation of ispconfig on two Ubuntu Jaunty servers, one of them for web, mail, ftp and everything and the second one only for mysql. On the web server I installed ispconfig and defined both servers in the configuration. Both servers are displayed correctly. If I open a ssh shell to the web server, I can connect to the mysql server from there by using the root account with a password.

    But if I define a new database within ispconfig, it doesn't show up on the mysql server. It just happens nothing. By using tcpdump, I found out that the web servers doesn't even try to connect to the mysql-server. The newly defined database is shown in ispconfig, but that's it. (It also does not show up on the local web server mysql database, jut for clarification)

    How to track down the problem, any hint would be fine. I'm not sure if I made a mistake and if so, how to find out which mistake.

  2. Mark_NL

    Mark_NL New Member

    Are the newly created databases created on the server itself instead of the other server?

    or are they nowhere to be found?
  3. captnnuss

    captnnuss New Member

    they are nowhere. I checked the web and the db-server. They only show up on the admin interface.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    How did you add the second server to the ispconfig installation?
  5. captnnuss

    captnnuss New Member

    I added the second (mysql) server by browsing to the first server (web) and from there:

    System -> Edit Server -> Add a new Server

    As the server name, I entered the FQDN and checked "DB-Server". After this, I edited the Web Server and unchecked "DB-Server" so that I just have one mysql server for customers.

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Servers can not be added in ispconfig like this, the server ahs to be added by the ispconfig installer during the installation of the second server. You will have to uninstall ispconfig from the second server and then reinstall it using expert mode and then enter the mysql login details of the master server when you get asked if you want to join a master server.
  7. captnnuss

    captnnuss New Member

    That explains everything. I don't even have ispconfig on the mysql-server as I just didn't know that I needed it.

    There is not much documentation for ispconfig3 at the moment. At least, I couldn't find it.

  8. captnnuss

    captnnuss New Member

    tried it that way now, but still doesn't work.

    I installed ispconfig3 on the mysql server in expert mode, joined the main ispconfig server database and set up everything.

    but when I create a new database on the main instance (webserver), it is shown in the ispconfig web page, but on the mysqlserver nothing happens. I thought that there should be created a database then, but even this doesn't happen.

    any hints?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you have most likely a permission problem. This happens e.g. when the hostnames of all servers are not registered in dns and so the master server is not able to resolve the hostname of the slave.

Share This Page