ISPConfig3 upgrade

Discussion in 'Installation/Configuration' started by dejvic, Aug 12, 2021.

  1. dejvic

    dejvic New Member

    now I have 3.1 and maybe upgrade to 3.2
    but i have this error

    Server: mail.dvcomputer.cz (Ubuntu 18.04.5 LTS (Bionic Beaver)) ISPConfig 3.1dev
    PHP Version 7.2.34-21+ubuntu18.04.1+deb.sury.org+1

    ------------------------------------
    [email protected]:/home/vana# ispconfig_update.sh
    PHP Fatal error: Uncaught Error: Call to undefined function get_magic_quotes_runtime() in /usr/local/ispconfig/server/lib/config.inc.php:48
    Stack trace:
    #0 /usr/local/ispconfig/server/scripts/ispconfig_update.php(75): require_once()
    #1 {main}
    thrown in /usr/local/ispconfig/server/lib/config.inc.php on line 48

    Please help me, thank you very much. David
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the command:

    php --version

    and post the result. I'm aware you posted a PHP version above, please do it anyway and post the result.
     
  3. dejvic

    dejvic New Member


    [email protected]:/var/www# php --version
    PHP 8.0.5 (cli) (built: May 1 2021 11:56:53) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v4.0.5, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.5, Copyright (c), by Zend Technologies
    [email protected]:/var/www#
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. dejvic

    dejvic New Member

  6. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    It is php7.2 as default for Ubuntu 18.04. Fix it following the steps in the link posted by @till above.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page